CVE-2025-27773 SimpleSAMLphp SAML2 library has incorrect signature verification for HTTP-Redirect binding

High 8.6 Published Updated

Attackers can bypass SAML signature verification in HTTP-Redirect binding, allowing acceptance of unsigned messages and potential authentication bypass.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-27773?

CVE-2025-27773 is a high-severity authentication bypass vulnerability in simplesamlphp saml2, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.17.0 and 5.0.0-alpha.20, there is a signature confusion attack in the HTTPRedirect binding. An attacker with any signed SAMLResponse via the HTTP-Redirect binding can cause the application to accept an unsigned message. Versions 4.17.0 and 5.0.0-alpha.20 contain a fix for the issue.

Weakness: CWE-347

Which versions are affected by CVE-2025-27773?

6 open source packages ship an affected version, including simplesamlphp/saml2 and simplesamlphp/saml2-legacy.

PackageAffectedFixed in
simplesamlphp/saml2 PackagistAll versions4.17.0
simplesamlphp/saml2 PackagistAll versions4.17.0
simplesamlphp/saml2 PackagistFrom 5.0.0-alpha.15.0.0-alpha.20
simplesamlphp/saml2 PackagistFrom 5.0.0-alpha.15.0.0-alpha.20
simplesamlphp/saml2-legacy PackagistAll versions4.17.0
simplesamlphp/saml2-legacy PackagistAll versions4.17.0

How do I fix CVE-2025-27773?

Upgrade simplesamlphp/saml2 to a fixed version for your release line: 4.17.0 or 5.0.0-alpha.20.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-27773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27773 exists.

Sources

Also known as DEBIAN-CVE-2025-27773, DLA-4161-1, GHSA-46r4-f8gj-xg56, UBUNTU-CVE-2025-27773.

Is CVE-2025-27773 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free