# CVE-2025-27773: SimpleSAMLphp SAML2 library has incorrect signature verification for HTTP-Redirect binding

> Attackers can bypass SAML signature verification in HTTP-Redirect binding, allowing acceptance of unsigned messages and potential authentication bypass.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2025
- **Updated:** 9 May 2025
- **Also known as:** DEBIAN-CVE-2025-27773, DLA-4161-1, GHSA-46r4-f8gj-xg56, UBUNTU-CVE-2025-27773

## What is CVE-2025-27773?

CVE-2025-27773 is a high-severity authentication bypass vulnerability in simplesamlphp saml2, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SimpleSAMLphp SAML2 library is a PHP library for SAML2 related functionality. Prior to versions 4.17.0 and 5.0.0-alpha.20, there is a signature confusion attack in the HTTPRedirect binding. An attacker with any signed SAMLResponse via the HTTP-Redirect binding can cause the application to accept an unsigned message. Versions 4.17.0 and 5.0.0-alpha.20 contain a fix for the issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-27773?

6 open source packages ship an affected version, including simplesamlphp/saml2 and simplesamlphp/saml2-legacy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/saml2` | Packagist | All versions | 4.17.0 |
| `simplesamlphp/saml2` | Packagist | All versions | 4.17.0 |
| `simplesamlphp/saml2` | Packagist | From 5.0.0-alpha.1 | 5.0.0-alpha.20 |
| `simplesamlphp/saml2` | Packagist | From 5.0.0-alpha.1 | 5.0.0-alpha.20 |
| `simplesamlphp/saml2-legacy` | Packagist | All versions | 4.17.0 |
| `simplesamlphp/saml2-legacy` | Packagist | All versions | 4.17.0 |

## How do I fix CVE-2025-27773?

Upgrade simplesamlphp/saml2 to a fixed version for your release line: 4.17.0 or 5.0.0-alpha.20.

## Is CVE-2025-27773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27773 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27773 and fix it if it is affected.

What it is: CVE-2025-27773 is a high-severity authentication bypass vulnerability in simplesamlphp saml2, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27773 exists.

Affected packages and fixed versions:
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 4.17.0
- simplesamlphp/saml2 (Packagist): affected all versions; fixed in 4.17.0
- simplesamlphp/saml2 (Packagist): affected from 5.0.0-alpha.1; fixed in 5.0.0-alpha.20
- simplesamlphp/saml2 (Packagist): affected from 5.0.0-alpha.1; fixed in 5.0.0-alpha.20
- simplesamlphp/saml2-legacy (Packagist): affected all versions; fixed in 4.17.0
- simplesamlphp/saml2-legacy (Packagist): affected all versions; fixed in 4.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27773/ (Markdown: https://insights.sbomify.com/CVE-2025-27773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27773
- OSV: https://osv.dev/vulnerability/CVE-2025-27773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27773/
Summaries are generated and may contain mistakes; the official description above is the record.
