{"answers":{"affected":"2 open source packages ship an affected version, including json. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27788 in the wild and no public exploit code.","fix":"Upgrade json to 2.10.2 or later.","what":"CVE-2025-27788 is a high-severity denial of service vulnerability in ruby json, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27788 and fix it if it is affected.\n\nWhat it is: CVE-2025-27788 is a high-severity denial of service vulnerability in ruby json, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27788 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- json (RubyGems): affected from 2.10.0; fixed in 2.10.2\n- json (RubyGems): affected from 2.10.0; fixed in 2.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27788/ (Markdown: https://insights.sbomify.com/CVE-2025-27788/index.md)","id":"CVE-2025-27788","markdown":"https://insights.sbomify.com/CVE-2025-27788/index.md","name":"CVE-2025-27788","record":{"aliases":["GHSA-9m3q-rhmv-5q44","MINI-9fr2-mqjm-5v6r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby JSON library","requires_auth":"none","summary":"A specially crafted JSON document can cause an out-of-bounds read and crash the application using the Ruby JSON library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"javascript_object_notation","vendor":"ruby-lang"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"JSON is a JSON implementation for Ruby. Starting in version 2.10.0 and prior to version 2.10.2, a specially crafted document could cause an out of bound read, most likely resulting in a crash. Versions prior to 2.10.0 are not vulnerable. Version 2.10.2 fixes the problem. No known workarounds are available.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ruby JSON Parser has Out-of-bounds Read","id":"CVE-2025-27788","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Inefficient RexExp complexity in generated code with .replace when transpiling named capturing groups","id":"CVE-2025-27789"},"packages":[{"ecosystem":"RubyGems","fixed":["2.10.2"],"introduced":["2.10.0"],"last_affected":[],"package":"json","purl":null,"source":"GHSA-9m3q-rhmv-5q44"},{"ecosystem":"RubyGems","fixed":["2.10.2"],"introduced":["2.10.0"],"last_affected":[],"package":"json","purl":"pkg:gem/json","source":"GHSA-9m3q-rhmv-5q44"}],"prev":{"headline":"Applio allows a DoS in restart.py","id":"CVE-2025-27787"},"products":["json"],"published":"2025-03-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-12","vendors":["ruby"]},"summary":"A specially crafted JSON document can cause an out-of-bounds read and crash the application using the Ruby JSON library.","url":"https://insights.sbomify.com/CVE-2025-27788/"}