# CVE-2025-27788: Ruby JSON Parser has Out-of-bounds Read

> A specially crafted JSON document can cause an out-of-bounds read and crash the application using the Ruby JSON library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2025
- **Updated:** 12 Mar 2025
- **Also known as:** GHSA-9m3q-rhmv-5q44, MINI-9fr2-mqjm-5v6r

## What is CVE-2025-27788?

CVE-2025-27788 is a high-severity denial of service vulnerability in ruby json, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JSON is a JSON implementation for Ruby. Starting in version 2.10.0 and prior to version 2.10.2, a specially crafted document could cause an out of bound read, most likely resulting in a crash. Versions prior to 2.10.0 are not vulnerable. Version 2.10.2 fixes the problem. No known workarounds are available.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2025-27788?

2 open source packages ship an affected version, including json. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `json` | RubyGems | From 2.10.0 | 2.10.2 |
| `json` | RubyGems | From 2.10.0 | 2.10.2 |

Products: Ruby-Lang Javascript Object Notation.

## How do I fix CVE-2025-27788?

Upgrade json to 2.10.2 or later.

## Is CVE-2025-27788 being exploited?

There is no known exploitation of CVE-2025-27788 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27788 and fix it if it is affected.

What it is: CVE-2025-27788 is a high-severity denial of service vulnerability in ruby json, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27788 in the wild and no public exploit code.

Affected packages and fixed versions:
- json (RubyGems): affected from 2.10.0; fixed in 2.10.2
- json (RubyGems): affected from 2.10.0; fixed in 2.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27788/ (Markdown: https://insights.sbomify.com/CVE-2025-27788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27788
- OSV: https://osv.dev/vulnerability/CVE-2025-27788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27788/
Summaries are generated and may contain mistakes; the official description above is the record.
