{"answers":{"affected":"4 open source packages ship an affected version, including vega and vega-functions.","exploited":"There is no known exploitation of CVE-2025-27793 in the wild and no public exploit code.","fix":"Upgrade vega to 5.32.0 or later.","what":"CVE-2025-27793 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-27793 and fix it if it is affected.\n\nWhat it is: CVE-2025-27793 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-27793 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vega (npm): affected all versions; fixed in 5.32.0\n- vega (npm): affected all versions; fixed in 5.32.0\n- vega-functions (npm): affected all versions; fixed in 5.17.0\n- vega-functions (npm): affected all versions; fixed in 5.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27793/ (Markdown: https://insights.sbomify.com/CVE-2025-27793/index.md)","id":"CVE-2025-27793","markdown":"https://insights.sbomify.com/CVE-2025-27793/index.md","name":"CVE-2025-27793","record":{"aliases":["DEBIAN-CVE-2025-27793","GHSA-963h-3v39-3pqf","UBUNTU-CVE-2025-27793"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Vega visualization library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via crafted Vega JSON definitions, impacting applications rendering untrusted visualizations.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-87","name":"Improper Neutralization of Alternate XSS Syntax"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 5.32.0, corresponding to vega-functions prior to version 5.17.0, users running Vega/Vega-lite JSON definitions could run unexpected JavaScript code when drawing graphs, unless the library was used with the `vega-interpreter`. Vega version 5.32.0 and vega-functions version 5.17.0 fix the issue. As a workaround, use `vega` with expression interpreter.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vega vulnerable to Cross-site Scripting via RegExp.prototype[@@replace]","id":"CVE-2025-27793","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794"},"packages":[{"ecosystem":"npm","fixed":["5.32.0"],"introduced":["0"],"last_affected":[],"package":"vega","purl":null,"source":"GHSA-963h-3v39-3pqf"},{"ecosystem":"npm","fixed":["5.32.0"],"introduced":["0"],"last_affected":[],"package":"vega","purl":"pkg:npm/vega","source":"GHSA-963h-3v39-3pqf"},{"ecosystem":"npm","fixed":["5.17.0"],"introduced":["0"],"last_affected":[],"package":"vega-functions","purl":null,"source":"GHSA-963h-3v39-3pqf"},{"ecosystem":"npm","fixed":["5.17.0"],"introduced":["0"],"last_affected":[],"package":"vega-functions","purl":"pkg:npm/vega-functions","source":"GHSA-963h-3v39-3pqf"}],"prev":{"headline":"Opal vulnerable to CSRF protection bypass","id":"CVE-2025-27792"},"products":["vega"],"published":"2025-03-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["vega"]},"summary":"Attackers can execute arbitrary JavaScript via crafted Vega JSON definitions, impacting applications rendering untrusted visualizations.","url":"https://insights.sbomify.com/CVE-2025-27793/"}