# CVE-2025-27793: Vega vulnerable to Cross-site Scripting via RegExp.prototype[@@replace]

> Attackers can execute arbitrary JavaScript via crafted Vega JSON definitions, impacting applications rendering untrusted visualizations.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2025
- **Updated:** 27 Mar 2025
- **Also known as:** DEBIAN-CVE-2025-27793, GHSA-963h-3v39-3pqf, UBUNTU-CVE-2025-27793

## What is CVE-2025-27793?

CVE-2025-27793 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 5.32.0, corresponding to vega-functions prior to version 5.17.0, users running Vega/Vega-lite JSON definitions could run unexpected JavaScript code when drawing graphs, unless the library was used with the `vega-interpreter`. Vega version 5.32.0 and vega-functions version 5.17.0 fix the issue. As a workaround, use `vega` with expression interpreter.

Weakness: CWE-87 (Improper Neutralization of Alternate XSS Syntax), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-27793?

4 open source packages ship an affected version, including vega and vega-functions.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vega` | npm | All versions | 5.32.0 |
| `vega` | npm | All versions | 5.32.0 |
| `vega-functions` | npm | All versions | 5.17.0 |
| `vega-functions` | npm | All versions | 5.17.0 |

## How do I fix CVE-2025-27793?

Upgrade vega to 5.32.0 or later.

## Is CVE-2025-27793 being exploited?

There is no known exploitation of CVE-2025-27793 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27793 and fix it if it is affected.

What it is: CVE-2025-27793 is a medium-severity cross-site scripting vulnerability in vega, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-27793 in the wild and no public exploit code.

Affected packages and fixed versions:
- vega (npm): affected all versions; fixed in 5.32.0
- vega (npm): affected all versions; fixed in 5.32.0
- vega-functions (npm): affected all versions; fixed in 5.17.0
- vega-functions (npm): affected all versions; fixed in 5.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27793/ (Markdown: https://insights.sbomify.com/CVE-2025-27793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27793
- OSV: https://osv.dev/vulnerability/CVE-2025-27793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27793/
Summaries are generated and may contain mistakes; the official description above is the record.
