{"answers":{"affected":"4 open source packages ship an affected version, including flarum/framework and flarum/core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27794 exists.","fix":"Upgrade flarum/framework to 1.8.10 or later.","what":"CVE-2025-27794 is a medium-severity authentication bypass vulnerability in flarum framework, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-27794 and fix it if it is affected.\n\nWhat it is: CVE-2025-27794 is a medium-severity authentication bypass vulnerability in flarum framework, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27794 exists.\n\nAffected packages and fixed versions:\n- flarum/framework (Packagist): affected all versions; fixed in 1.8.10\n- flarum/framework (Packagist): affected all versions; fixed in 1.8.10\n- flarum/core (Packagist): affected all versions; fixed in 1.8.10\n- flarum/core (Packagist): affected all versions; fixed in 1.8.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27794/ (Markdown: https://insights.sbomify.com/CVE-2025-27794/index.md)","id":"CVE-2025-27794","markdown":"https://insights.sbomify.com/CVE-2025-27794/index.md","name":"CVE-2025-27794","record":{"aliases":["GHSA-hg9j-64wp-m9px"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum forum software","requires_auth":"none","summary":"Attackers controlling a sibling subdomain can hijack user sessions in Flarum by overwriting parent-domain cookies, leading to account takeover.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flarum","vendor":"flarum"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Flarum is open-source forum software. A session hijacking vulnerability exists in versions prior to 1.8.10 when an attacker-controlled authoritative subdomain under a parent domain (e.g., `subdomain.host.com`) sets cookies scoped to the parent domain (`.host.com`). This allows session token replacement for applications hosted on sibling subdomains (e.g., `community.host.com`) if session tokens aren't rotated post-authentication. Key Constraints are that the attacker must control any subdomain under the parent domain (e.g., `evil.host.com` or `x.y.host.com`), and the parent domain must not be on the Public Suffix List. Due to non-existent session token rotation after authenticating we can theoretically reproduce the vulnerability by using browser dev tools, but due to the browser's security measures this does not seem to be exploitable as described. Version 1.8.10 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"Denial of service in GraphicsMagick","id":"CVE-2025-27795"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.10"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-hg9j-64wp-m9px"},{"ecosystem":"Packagist","fixed":["1.8.10"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-hg9j-64wp-m9px"},{"ecosystem":"Packagist","fixed":["1.8.10"],"introduced":["0"],"last_affected":[],"package":"flarum/framework","purl":null,"source":"GHSA-hg9j-64wp-m9px"},{"ecosystem":"Packagist","fixed":["1.8.10"],"introduced":["0"],"last_affected":[],"package":"flarum/framework","purl":"pkg:composer/flarum/framework","source":"GHSA-hg9j-64wp-m9px"}],"prev":{"headline":"Vega vulnerable to Cross-site Scripting via RegExp.prototype[@@replace]","id":"CVE-2025-27793"},"products":["framework"],"published":"2025-03-12","related":[{"cvss_score":10,"headline":"XSS vulnerability with translator","id":"CVE-2021-32671","kev_date_added":null,"published":"2021-06-07"},{"cvss_score":9,"headline":"Cross site scripting vulnerability with discussion titles in flarum","id":"CVE-2022-41938","kev_date_added":null,"published":"2022-11-19"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13183","kev_date_added":null,"published":"2019-07-07"},{"cvss_score":7.7,"headline":"Post mentions can be used to read any post on the forum without access control","id":"CVE-2023-22487","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":7.5,"headline":"Flarum mishandles invalidation of user email tokens","id":"CVE-2019-11514","kev_date_added":null,"published":"2019-04-25"},{"cvss_score":7.1,"headline":"Server-Side Request Forgery via Avatar upload in flarum","id":"CVE-2023-40033","kev_date_added":null,"published":"2023-08-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-12","vendors":["flarum"]},"summary":"Attackers controlling a sibling subdomain can hijack user sessions in Flarum by overwriting parent-domain cookies, leading to account takeover.","url":"https://insights.sbomify.com/CVE-2025-27794/"}