# CVE-2025-27794: Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite

> Attackers controlling a sibling subdomain can hijack user sessions in Flarum by overwriting parent-domain cookies, leading to account takeover.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2025
- **Updated:** 12 Mar 2025
- **Also known as:** GHSA-hg9j-64wp-m9px

## What is CVE-2025-27794?

CVE-2025-27794 is a medium-severity authentication bypass vulnerability in flarum framework, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Flarum is open-source forum software. A session hijacking vulnerability exists in versions prior to 1.8.10 when an attacker-controlled authoritative subdomain under a parent domain (e.g., `subdomain.host.com`) sets cookies scoped to the parent domain (`.host.com`). This allows session token replacement for applications hosted on sibling subdomains (e.g., `community.host.com`) if session tokens aren't rotated post-authentication. Key Constraints are that the attacker must control any subdomain under the parent domain (e.g., `evil.host.com` or `x.y.host.com`), and the parent domain must not be on the Public Suffix List. Due to non-existent session token rotation after authenticating we can theoretically reproduce the vulnerability by using browser dev tools, but due to the browser's security measures this does not seem to be exploitable as described. Version 1.8.10 contains a patch for the issue.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-27794?

4 open source packages ship an affected version, including flarum/framework and flarum/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flarum/framework` | Packagist | All versions | 1.8.10 |
| `flarum/framework` | Packagist | All versions | 1.8.10 |
| `flarum/core` | Packagist | All versions | 1.8.10 |
| `flarum/core` | Packagist | All versions | 1.8.10 |

Products: Flarum Flarum.

## How do I fix CVE-2025-27794?

Upgrade flarum/framework to 1.8.10 or later.

## Is CVE-2025-27794 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27794 exists.

## Other vulnerabilities in flarum framework

- [CVE-2021-32671](https://insights.sbomify.com/CVE-2021-32671/): XSS vulnerability with translator (critical 10.0)
- [CVE-2022-41938](https://insights.sbomify.com/CVE-2022-41938/): Cross site scripting vulnerability with discussion titles in flarum (critical 9.0)
- [CVE-2019-13183](https://insights.sbomify.com/CVE-2019-13183/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2023-22487](https://insights.sbomify.com/CVE-2023-22487/): Post mentions can be used to read any post on the forum without access control (high 7.7)
- [CVE-2019-11514](https://insights.sbomify.com/CVE-2019-11514/): Flarum mishandles invalidation of user email tokens (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27794 and fix it if it is affected.

What it is: CVE-2025-27794 is a medium-severity authentication bypass vulnerability in flarum framework, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27794 exists.

Affected packages and fixed versions:
- flarum/framework (Packagist): affected all versions; fixed in 1.8.10
- flarum/framework (Packagist): affected all versions; fixed in 1.8.10
- flarum/core (Packagist): affected all versions; fixed in 1.8.10
- flarum/core (Packagist): affected all versions; fixed in 1.8.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27794/ (Markdown: https://insights.sbomify.com/CVE-2025-27794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27794
- OSV: https://osv.dev/vulnerability/CVE-2025-27794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27794/
Summaries are generated and may contain mistakes; the official description above is the record.
