# CVE-2025-27818: Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration

> Authenticated operators can trigger remote code execution on Kafka Connect by configuring malicious SASL JAAS LDAP settings that exploit unsafe deserialization.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-kafka-2025-27818, ECHO-6971-a227-7838, GHSA-76qp-h5mr-frr4, MINI-5645-9xq5-xhrr, MINI-65m6-qc5c-22q4, MINI-c47f-c47w-gqpv, MINI-q3ww-5r8q-55q4, MINI-wgpc-gvrq-pg4p, MINI-xj4w-q84w-f8wx, ROOT-APP-MAVEN-CVE-2025-27818

## What is CVE-2025-27818?

CVE-2025-27818 is a high-severity unsafe deserialization vulnerability in Apache Kafka, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A possible security vulnerability has been identified in Apache Kafka.
This requires access to a alterConfig to the cluster resource, or Kafka Connect worker, and the ability to create/modify connectors on it with an arbitrary Kafka client SASL JAAS config
and a SASL-based security protocol, which has been possible on Kafka clusters since Apache Kafka 2.0.0 (Kafka Connect 2.3.0).
When configuring the broker via config file or AlterConfig command, or connector via the Kafka Kafka Connect REST API, an authenticated operator can set the `sasl.jaas.config`
property for any of the connector's Kafka clients to "com.sun.security.auth.module.LdapLoginModule", which can be done via the
`producer.override.sasl.jaas.config`, `consumer.override.sasl.jaas.config`, or `admin.override.sasl.jaas.config` properties.
This will allow the server to connect to the attacker's LDAP server
and deserialize the LDAP response, which the attacker can use to execute java deserialization gadget chains on the Kafka connect server.
Attacker can cause unrestricted deserialization of untrusted data (or) RCE vulnerability when there are gadgets in the classpath.

Since Apache Kafka 3.0.0, users are allowed to specify these properties in connector configurations for Kafka Connect clusters running with out-of-the-box
configurations. Before Apache Kafka 3.0.0, users may not specify these properties unless the Kafka Connect cluster has been reconfigured with a connector
client override policy that permits them.

Since Apache Kafka 3.9.1/4.0.0, we have added a system property ("-Dorg.apache.kafka.disallowed.login.modules") to disable the problematic login modules usage
in SASL JAAS configuration. Also by default "com.sun.security.auth.module.JndiLoginModule,com.sun.security.auth.module.LdapLoginModule" are disabled in Apache Kafka Connect 3.9.1/4.0.0. 

We advise the Kafka users to validate connector configurations and only allow trusted LDAP configurations. Also examine connector dependencies for 
vulnerable versions and either upgrade their connectors, upgrading that specific dependency, or removing the connectors as options for remediation. Finally,
in addition to leveraging the "org.apache.kafka.disallowed.login.modules" system property, Kafka Connect users can also implement their own connector
client config override policy, which can be used to control which Kafka client properties can be overridden directly in a connector config and which cannot.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-27818?

7 open source packages ship an affected version, including org.apache.kafka:kafka_2.11, kafka and org.apache.kafka:kafka_2.12. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kafka:kafka_2.11` | Maven | From 2.3.0 to 2.4.1 | None |
| `org.apache.kafka:kafka_2.11` | Maven | From 2.3.0 to 2.4.1 | None |
| `kafka` | Bitnami | From 2.3.0 | 3.9.1 |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.3.0 | 3.9.1 |
| `org.apache.kafka:kafka_2.12` | Maven | From 2.3.0 | 3.9.1 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.4.0 | 3.9.1 |
| `org.apache.kafka:kafka_2.13` | Maven | From 2.4.0 | 3.9.1 |

Products: Apache Kafka.

## How do I fix CVE-2025-27818?

Change a configuration setting.

## Is CVE-2025-27818 being exploited?

There is no known exploitation of CVE-2025-27818 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kafka

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2018-17196](https://insights.sbomify.com/CVE-2018-17196/): Improper Input Validation in Apache Kafka (high 8.8)
- [CVE-2026-35554](https://insights.sbomify.com/CVE-2026-35554/): Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition (high 8.7)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)
- [CVE-2025-27819](https://insights.sbomify.com/CVE-2025-27819/): Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27818 and fix it if it is affected.

What it is: CVE-2025-27818 is a high-severity unsafe deserialization vulnerability in Apache Kafka, published on 10 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27818 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kafka:kafka_2.11 (Maven): affected from 2.3.0 up to 2.4.1; no fix listed
- org.apache.kafka:kafka_2.11 (Maven): affected from 2.3.0 up to 2.4.1; no fix listed
- kafka (Bitnami): affected from 2.3.0; fixed in 3.9.1
- org.apache.kafka:kafka_2.12 (Maven): affected from 2.3.0; fixed in 3.9.1
- org.apache.kafka:kafka_2.12 (Maven): affected from 2.3.0; fixed in 3.9.1
- org.apache.kafka:kafka_2.13 (Maven): affected from 2.4.0; fixed in 3.9.1
- org.apache.kafka:kafka_2.13 (Maven): affected from 2.4.0; fixed in 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27818/ (Markdown: https://insights.sbomify.com/CVE-2025-27818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27818
- OSV: https://osv.dev/vulnerability/CVE-2025-27818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27818/
Summaries are generated and may contain mistakes; the official description above is the record.
