CVE-2025-27820 Apache HttpComponents: PSL (Public Suffix List) validation bypass

High 7.5 Published Updated

Attackers can bypass domain validation checks in Apache HttpClient, potentially compromising cookie management and host name verification.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-27820?

CVE-2025-27820 is a high-severity vulnerability in Apache HttpComponents, published on 24 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A bug in PSL validation logic in Apache HttpClient 5.4.x disables domain checks, affecting cookie management and host name verification. Discovered by the Apache HttpClient team. Fixed in the 5.4.3 release

Weakness: CWE-295

Which versions are affected by CVE-2025-27820?

2 open source packages ship an affected version, including org.apache.httpcomponents.client5:httpclient5. It affects 2 products.

PackageAffectedFixed in
org.apache.httpcomponents.client5:httpclient5 MavenFrom 5.4-alpha15.4.3
org.apache.httpcomponents.client5:httpclient5 MavenFrom 5.4-alpha15.4.3

Products include Apache Httpclient, Netapp Ontap Tools.

How do I fix CVE-2025-27820?

Upgrade org.apache.httpcomponents.client5:httpclient5 to 5.4.3 or later.

Is CVE-2025-27820 being exploited?

There is no known exploitation of CVE-2025-27820 in the wild and no public exploit code.

Sources

Also known as GHSA-73m2-qfq3-56cx, MINI-8pc5-2xv5-mjxm, UBUNTU-CVE-2025-27820.

Is CVE-2025-27820 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free