CVE-2025-27821 HDFS native client: Out of bounds write in URI parser of native HDFS client

High 7.3 Published Updated

An out-of-bounds write in the HDFS native client URI parser allows attackers to potentially execute code or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-27821?

CVE-2025-27821 is a high-severity memory corruption vulnerability in Apache Software Foundation HDFS native client, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Weakness: CWE-787

Which versions are affected by CVE-2025-27821?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-hdfs-native-client. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-hdfs-native-client MavenFrom 3.2.03.4.2
org.apache.hadoop:hadoop-hdfs-native-client MavenFrom 3.2.03.4.2

Products include Apache Hadoop.

How do I fix CVE-2025-27821?

Upgrade org.apache.hadoop:hadoop-hdfs-native-client to 3.4.2 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-27821 being exploited?

There is no known exploitation of CVE-2025-27821 in the wild and no public exploit code.

Sources

Also known as CLEANSTART-2026-HK83205, GHSA-92cc-952p-v8rh.

Is CVE-2025-27821 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free