# CVE-2025-27821: HDFS native client: Out of bounds write in URI parser of native HDFS client

> An out-of-bounds write in the HDFS native client URI parser allows attackers to potentially execute code or cause denial of service.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 26 Jan 2026
- **Also known as:** CLEANSTART-2026-HK83205, GHSA-92cc-952p-v8rh

## What is CVE-2025-27821?

CVE-2025-27821 is a high-severity memory corruption vulnerability in Apache Software Foundation HDFS native client, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Out-of-bounds Write vulnerability in Apache Hadoop HDFS native client.

This issue affects Apache Hadoop: from 3.2.0 before 3.4.2.

Users are recommended to upgrade to version 3.4.2, which fixes the issue.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2025-27821?

2 open source packages ship an affected version, including org.apache.hadoop:hadoop-hdfs-native-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-hdfs-native-client` | Maven | From 3.2.0 | 3.4.2 |
| `org.apache.hadoop:hadoop-hdfs-native-client` | Maven | From 3.2.0 | 3.4.2 |

Products: Apache Hadoop.

## How do I fix CVE-2025-27821?

Upgrade org.apache.hadoop:hadoop-hdfs-native-client to 3.4.2 or later.

## Is CVE-2025-27821 being exploited?

There is no known exploitation of CVE-2025-27821 in the wild and no public exploit code.

## Other vulnerabilities in Apache Software Foundation HDFS native client

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27821 and fix it if it is affected.

What it is: CVE-2025-27821 is a high-severity memory corruption vulnerability in Apache Software Foundation HDFS native client, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27821 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-hdfs-native-client (Maven): affected from 3.2.0; fixed in 3.4.2
- org.apache.hadoop:hadoop-hdfs-native-client (Maven): affected from 3.2.0; fixed in 3.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27821/ (Markdown: https://insights.sbomify.com/CVE-2025-27821/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27821
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27821
- OSV: https://osv.dev/vulnerability/CVE-2025-27821

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27821/
Summaries are generated and may contain mistakes; the official description above is the record.
