{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.felix:org.apache.felix.http.webconsoleplugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-27867 in the wild and no public exploit code.","fix":"Upgrade org.apache.felix:org.apache.felix.http.webconsoleplugin to 1.2.2 or later.","what":"CVE-2025-27867 is a medium-severity cross-site scripting vulnerability in Apache Felix HTTP Webconsole Plugin, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-27867 and fix it if it is affected.\n\nWhat it is: CVE-2025-27867 is a medium-severity cross-site scripting vulnerability in Apache Felix HTTP Webconsole Plugin, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-27867 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.felix:org.apache.felix.http.webconsoleplugin (Maven): affected all versions; fixed in 1.2.2\n- org.apache.felix:org.apache.felix.http.webconsoleplugin (Maven): affected all versions; fixed in 1.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-27867/ (Markdown: https://insights.sbomify.com/CVE-2025-27867/index.md)","id":"CVE-2025-27867","markdown":"https://insights.sbomify.com/CVE-2025-27867/index.md","name":"CVE-2025-27867","record":{"aliases":["GHSA-2cv6-4f2r-jq2c"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Felix Webconsole","requires_auth":"none","summary":"Attackers can inject malicious scripts into the Apache Felix HTTP Webconsole, potentially compromising user sessions or executing code.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"felix_http_webconsole_plugin","vendor":"apache"}],"cvss":{"score":5.6,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Felix HTTP Webconsole Plugin.\n\nThis issue affects Apache Felix HTTP Webconsole Plugin: from Version 1.X through 1.2.0.\n\nUsers are recommended to upgrade to version 1.2.2, which fixes the issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Felix HTTP Webconsole Plugin: XSS in HTTP Webconsole Plugin","id":"CVE-2025-27867","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Druid: Server-Side Request Forgery and Cross-Site Scripting","id":"CVE-2025-27888"},"packages":[{"ecosystem":"Maven","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.felix:org.apache.felix.http.webconsoleplugin","purl":null,"source":"GHSA-2cv6-4f2r-jq2c"},{"ecosystem":"Maven","fixed":["1.2.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.felix:org.apache.felix.http.webconsoleplugin","purl":"pkg:maven/org.apache.felix/org.apache.felix.http.webconsoleplugin","source":"GHSA-2cv6-4f2r-jq2c"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2025-27853"},"products":["Apache Felix HTTP Webconsole Plugin"],"published":"2025-03-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-21","vendors":["Apache Software Foundation"]},"summary":"Attackers can inject malicious scripts into the Apache Felix HTTP Webconsole, potentially compromising user sessions or executing code.","url":"https://insights.sbomify.com/CVE-2025-27867/"}