# CVE-2025-27892: Shopware Vulnerable to Blind SQL-injection in DAL aggregations

> Attackers can exploit SQL injection in the order search API to read or modify database contents in Shopware installations.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-8g35-7rmw-7f59

## What is CVE-2025-27892?

CVE-2025-27892 is a medium-severity SQL injection vulnerability in Shopware Shopware, published on 15 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the /api/search/order endpoint. NOTE: this issue exists because of a CVE-2024-22406 and CVE-2024-42357 regression.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-27892?

12 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.5.8.18 |
| `shopware/core` | Packagist | All versions | 6.5.8.18 |
| `shopware/core` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/core` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/core` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
| `shopware/core` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
| `shopware/platform` | Packagist | All versions | 6.5.8.18 |
| `shopware/platform` | Packagist | All versions | 6.5.8.18 |
| `shopware/platform` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/platform` | Packagist | From 6.6.0.0 | 6.6.10.3 |
| `shopware/platform` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
| `shopware/platform` | Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |

Products: Shopware Shopware.

## How do I fix CVE-2025-27892?

Upgrade shopware/core to a fixed version for your release line: 6.5.8.18, 6.6.10.3 or 6.7.0.0-rc2.

## Is CVE-2025-27892 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27892 exists.

Public exploit code:

- Shopware < 6.5.8.13 - SQL Injection (nuclei): http/cves/2025/CVE-2025-27892.yaml

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27892 and fix it if it is affected.

What it is: CVE-2025-27892 is a medium-severity SQL injection vulnerability in Shopware Shopware, published on 15 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-27892 exists.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/core (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/core (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/core (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/core (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2
- shopware/core (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2
- shopware/platform (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/platform (Packagist): affected all versions; fixed in 6.5.8.18
- shopware/platform (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/platform (Packagist): affected from 6.6.0.0; fixed in 6.6.10.3
- shopware/platform (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2
- shopware/platform (Packagist): affected from 6.7.0.0-rc1; fixed in 6.7.0.0-rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27892/ (Markdown: https://insights.sbomify.com/CVE-2025-27892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27892
- OSV: https://osv.dev/vulnerability/CVE-2025-27892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27892/
Summaries are generated and may contain mistakes; the official description above is the record.
