CVE-2025-27933 Unauthorized Private-to-Public Channel Conversion

Medium 5.4 Published Updated

Attackers with public-to-private conversion rights can improperly convert private channels to public, exposing private data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-27933?

CVE-2025-27933 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to fail to enforce channel conversion restrictions, which allows members with permission to convert public channels to private ones to also convert private ones to public

Weakness: CWE-863

Which versions are affected by CVE-2025-27933?

15 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250218135018-e644e3c8e393
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250218135018-e644e3c8e393
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250218135018-e644e3c8e393
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.010.3.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.3.010.3.4
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.3
9 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.4.010.4.3
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.9
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.9
mattermost BitnamiFrom 9.11.010.0.0, 10.5.1
github.com/mattermost/mattermost-server GoAll versions9.11.9
github.com/mattermost/mattermost-server GoAll versions9.11.9
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.9+incompatible, 10.3.4+incompatible, 10.4.3+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-27933?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250218135018-e644e3c8e393, 10.3.4, 10.4.3 or 9.11.9.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-27933 being exploited?

There is no known exploitation of CVE-2025-27933 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2025-27933, GHSA-h5v9-xw2g-7hrq, GO-2025-3556.

Is CVE-2025-27933 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free