# CVE-2025-27933: Unauthorized Private-to-Public Channel Conversion

> Attackers with public-to-private conversion rights can improperly convert private channels to public, exposing private data.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Mar 2025
- **Updated:** 21 Mar 2025
- **Also known as:** BIT-mattermost-2025-27933, GHSA-h5v9-xw2g-7hrq, GO-2025-3556

## What is CVE-2025-27933?

CVE-2025-27933 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.4.x <= 10.4.2, 10.3.x <= 10.3.3, 9.11.x <= 9.11.8 fail to fail to enforce channel conversion restrictions, which allows members with permission to convert public channels to private ones to also convert private ones to public

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-27933?

15 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218135018-e644e3c8e393 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218135018-e644e3c8e393 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218135018-e644e3c8e393 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.3.0 | 10.3.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.3.0 | 10.3.4 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.4.0 | 10.4.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.4.0 | 10.4.3 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | 9.11.9 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | 9.11.9 |
| `mattermost` | Bitnami | From 9.11.0 | 10.0.0, 10.5.1 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 9.11.9 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 9.11.9 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0+incompatible | 9.11.9+incompatible, 10.3.4+incompatible, 10.4.3+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-27933?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250218135018-e644e3c8e393, 10.3.4, 10.4.3 or 9.11.9.

## Is CVE-2025-27933 being exploited?

There is no known exploitation of CVE-2025-27933 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27933 and fix it if it is affected.

What it is: CVE-2025-27933 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 21 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27933 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218135018-e644e3c8e393
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218135018-e644e3c8e393
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218135018-e644e3c8e393
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.3.0; fixed in 10.3.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.3.0; fixed in 10.3.4
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.4.0; fixed in 10.4.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.4.0; fixed in 10.4.3
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; fixed in 9.11.9
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; fixed in 9.11.9
- mattermost (Bitnami): affected from 9.11.0; fixed in 10.0.0, 10.5.1
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 9.11.9
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 9.11.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27933/ (Markdown: https://insights.sbomify.com/CVE-2025-27933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27933
- OSV: https://osv.dev/vulnerability/CVE-2025-27933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27933/
Summaries are generated and may contain mistakes; the official description above is the record.
