# CVE-2025-27936: Webhook Secret Exposure via Timing attack in MSteams plugin

> An attacker can retrieve the webhook secret via a timing attack in the Mattermost MS Teams plugin, requiring the plugin to be enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2025
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-2j87-p623-8cc2, GO-2025-3618

## What is CVE-2025-27936?

CVE-2025-27936 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost Plugin MSTeams versions <2.1.0 and Mattermost Server versions 10.5.x <=10.5.1 with the MS Teams plugin enabled fail to perform constant time comparison on a MSTeams plugin webhook secret which allows an attacker to retrieve the webhook secret of the MSTeams plugin via a timing attack during webhook secret comparison.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2025-27936?

11 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-plugin-msteams and github.com/mattermost/mattermost-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250314142426-c049748b8863 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250314142426-c049748b8863 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | 10.5.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | 10.5.2 |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | None |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 2.1.0 |
| `github.com/mattermost/mattermost-plugin-msteams` | Go | All versions | 2.1.0 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0+incompatible | 10.5.2+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server, Mattermost Ms Teams.

## How do I fix CVE-2025-27936?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250218121836-2b5275d87136, 8.0.0-20250314142426-c049748b8863 or 10.5.2.

## Is CVE-2025-27936 being exploited?

There is no known exploitation of CVE-2025-27936 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-27936 and fix it if it is affected.

What it is: CVE-2025-27936 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-27936 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250314142426-c049748b8863
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250314142426-c049748b8863
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; fixed in 10.5.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; fixed in 10.5.2
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 2.1.0
- github.com/mattermost/mattermost-plugin-msteams (Go): affected all versions; fixed in 2.1.0
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0+incompatible; fixed in 10.5.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-27936/ (Markdown: https://insights.sbomify.com/CVE-2025-27936/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-27936
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-27936
- OSV: https://osv.dev/vulnerability/CVE-2025-27936

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-27936/
Summaries are generated and may contain mistakes; the official description above is the record.
