{"answers":{"affected":"3 open source packages ship an affected version, including langchain-community. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2828 exists.","fix":"Upgrade langchain-community to 0.0.28 or later.","what":"CVE-2025-2828 is a high-severity server-side request forgery vulnerability in langchain-ai/langchain, published on 23 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-2828 and fix it if it is affected.\n\nWhat it is: CVE-2025-2828 is a high-severity server-side request forgery vulnerability in langchain-ai/langchain, published on 23 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2828 exists.\n\nAffected packages and fixed versions:\n- langchain-community (PyPI): affected all versions; fixed in 0.0.28\n- langchain-community (PyPI): affected all versions; fixed in 0.0.28\n- langchain-community (PyPI): affected all versions; fixed in 0.0.28\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-2828/ (Markdown: https://insights.sbomify.com/CVE-2025-2828/index.md)","id":"CVE-2025-2828","markdown":"https://insights.sbomify.com/CVE-2025-2828/index.md","name":"CVE-2025-2828","record":{"aliases":["GHSA-h5gc-rm8j-5gpr","PYSEC-2025-70"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI library","requires_auth":"high_privilege","summary":"Attackers can exploit SSRF in RequestsToolkit to access local services and cloud metadata, requiring an upgrade to the langchain-community package.","user_interaction":"required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":8.4,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchain_community.agent_toolkits.openapi.toolkit.RequestsToolkit) in langchain-ai/langchain version 0.0.27. This vulnerability occurs because the toolkit does not enforce restrictions on requests to remote internet addresses, allowing it to also access local addresses. As a result, an attacker could exploit this flaw to perform port scans, access local services, retrieve instance metadata from cloud environments (e.g., Azure, AWS), and interact with servers on the local network. This issue has been fixed in version 0.0.28.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"SSRF Vulnerability in RequestsToolkit in langchain-ai/langchain","id":"CVE-2025-2828","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Local Code Execution Vulnerability in Arena®","id":"CVE-2025-2829"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.28"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":null,"source":"GHSA-h5gc-rm8j-5gpr"},{"ecosystem":"PyPI","fixed":["0.0.28"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"GHSA-h5gc-rm8j-5gpr"},{"ecosystem":"PyPI","fixed":["0.0.28"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"PYSEC-2025-70"}],"prev":{"headline":"IBM Sterling File Gateway information disclosure","id":"CVE-2025-2827"},"products":["langchain-ai/langchain"],"published":"2025-06-23","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-24","vendors":["langchain-ai"]},"summary":"Attackers can exploit SSRF in RequestsToolkit to access local services and cloud metadata, requiring an upgrade to the langchain-community package.","url":"https://insights.sbomify.com/CVE-2025-2828/"}