# CVE-2025-2828: SSRF Vulnerability in RequestsToolkit in langchain-ai/langchain

> Attackers can exploit SSRF in RequestsToolkit to access local services and cloud metadata, requiring an upgrade to the langchain-community package.

- **Severity:** High 8.4 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2025
- **Updated:** 24 Jun 2025
- **Also known as:** GHSA-h5gc-rm8j-5gpr, PYSEC-2025-70

## What is CVE-2025-2828?

CVE-2025-2828 is a high-severity server-side request forgery vulnerability in langchain-ai/langchain, published on 23 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability exists in the RequestsToolkit component of the langchain-community package (specifically, langchain_community.agent_toolkits.openapi.toolkit.RequestsToolkit) in langchain-ai/langchain version 0.0.27. This vulnerability occurs because the toolkit does not enforce restrictions on requests to remote internet addresses, allowing it to also access local addresses. As a result, an attacker could exploit this flaw to perform port scans, access local services, retrieve instance metadata from cloud environments (e.g., Azure, AWS), and interact with servers on the local network. This issue has been fixed in version 0.0.28.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-2828?

3 open source packages ship an affected version, including langchain-community. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-community` | PyPI | All versions | 0.0.28 |
| `langchain-community` | PyPI | All versions | 0.0.28 |
| `langchain-community` | PyPI | All versions | 0.0.28 |

Products: Langchain Langchain.

## How do I fix CVE-2025-2828?

Upgrade langchain-community to 0.0.28 or later.

## Is CVE-2025-2828 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2828 exists.

## Other vulnerabilities in langchain-ai/langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2828 and fix it if it is affected.

What it is: CVE-2025-2828 is a high-severity server-side request forgery vulnerability in langchain-ai/langchain, published on 23 Jun 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2828 exists.

Affected packages and fixed versions:
- langchain-community (PyPI): affected all versions; fixed in 0.0.28
- langchain-community (PyPI): affected all versions; fixed in 0.0.28
- langchain-community (PyPI): affected all versions; fixed in 0.0.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2828/ (Markdown: https://insights.sbomify.com/CVE-2025-2828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2828
- OSV: https://osv.dev/vulnerability/CVE-2025-2828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2828/
Summaries are generated and may contain mistakes; the official description above is the record.
