# CVE-2025-2843: Observability-operator: observability operator privilege escalation

> A tenant with namespace-level access can escalate to cluster-level privileges by impersonating a ServiceAccount created by the Observability Operator.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Nov 2025
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-mj6p-p843-x5wc, GO-2025-4125

## What is CVE-2025-2843?

CVE-2025-2843 is a high-severity vulnerability in Red Hat Cluster Observability Operator 1.3.1, published on 12 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in the Observability Operator. The Operator creates a ServiceAccount with *ClusterRole* upon deployment of the *Namespace-Scoped* Custom Resource MonitorStack. This issue allows an adversarial Kubernetes Account with only namespaced-level roles, for example, a tenant controlling a namespace, to create a MonitorStack in the authorized namespace and then elevate permission to the cluster level by impersonating the ServiceAccount created by the Operator, resulting in privilege escalation and other issues.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-2843?

3 open source packages ship an affected version, including github.com/rhobs/observability-operator.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rhobs/observability-operator` | Go | All versions | 1.3.0 |
| `github.com/rhobs/observability-operator` | Go | All versions | 1.3.0 |
| `github.com/rhobs/observability-operator` | Go | All versions | 1.3.0 |

## How do I fix CVE-2025-2843?

Upgrade github.com/rhobs/observability-operator to 1.3.0 or later.

## Is CVE-2025-2843 being exploited?

There is no known exploitation of CVE-2025-2843 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2843 and fix it if it is affected.

What it is: CVE-2025-2843 is a high-severity vulnerability in Red Hat Cluster Observability Operator 1.3.1, published on 12 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-2843 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rhobs/observability-operator (Go): affected all versions; fixed in 1.3.0
- github.com/rhobs/observability-operator (Go): affected all versions; fixed in 1.3.0
- github.com/rhobs/observability-operator (Go): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2843/ (Markdown: https://insights.sbomify.com/CVE-2025-2843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2843
- OSV: https://osv.dev/vulnerability/CVE-2025-2843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2843/
Summaries are generated and may contain mistakes; the official description above is the record.
