{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2849 exists.","fix":"Apply the vendor's patch.","what":"CVE-2025-2849 is a medium-severity memory corruption vulnerability in UPX, published on 27 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-2849 and fix it if it is affected.\n\nWhat it is: CVE-2025-2849 is a medium-severity memory corruption vulnerability in UPX, published on 27 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2849 exists.\n\nAffected product: UPX. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-2849/ (Markdown: https://insights.sbomify.com/CVE-2025-2849/index.md)","id":"CVE-2025-2849","markdown":"https://insights.sbomify.com/CVE-2025-2849/index.md","name":"CVE-2025-2849","record":{"aliases":["DEBIAN-CVE-2025-2849","GHSA-jrx7-5cr9-c5v4","MGASA-2025-0122","UBUNTU-CVE-2025-2849","openSUSE-SU-2025:14947-1"],"analysis":{"component_type":"developer_tool","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"UPX executable packer","requires_auth":"low_privilege","summary":"A heap-based buffer overflow in UPX allows local attackers to execute arbitrary code or cause denial of service via crafted ELF files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"upx","vendor":"upx"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"},{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability, which was classified as problematic, was found in UPX up to 5.0.0. Affected is the function PackLinuxElf64::un_DT_INIT of the file src/p_lx_elf.cpp. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. The patch is identified as e0b6ff192412f5bb5364c1948f4f6b27a0cd5ea2. It is recommended to apply a patch to fix this issue.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"UPX p_lx_elf.cpp un_DT_INIT heap-based overflow","id":"CVE-2025-2849","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":7,"next":{"headline":"GL.iNet GL-A1300 Slate Plus Download Interface improper authorization","id":"CVE-2025-2850"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.0.0-2.1"],"introduced":["0"],"last_affected":[],"package":"upx","purl":"pkg:rpm/opensuse/upx\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14947-1"}],"prev":{"headline":"Missing authorization in Synology Mail Server","id":"CVE-2025-2848"},"products":["UPX"],"published":"2025-03-27","related":[{"cvss_score":7.8,"headline":"Memory corruption in upx","id":"CVE-2020-27796","kev_date_added":null,"published":"2022-08-25"},{"cvss_score":7.8,"headline":"Memory corruption in upx","id":"CVE-2020-27799","kev_date_added":null,"published":"2022-08-25"},{"cvss_score":7.8,"headline":"Memory corruption in upx","id":"CVE-2020-27800","kev_date_added":null,"published":"2022-08-25"},{"cvss_score":7.8,"headline":"Memory corruption in upx","id":"CVE-2020-27801","kev_date_added":null,"published":"2022-08-25"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2019-14296","kev_date_added":null,"published":"2019-07-27"},{"cvss_score":7.8,"headline":"Use after free in n/a","id":"CVE-2018-11243","kev_date_added":null,"published":"2018-05-18"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2017-16869","kev_date_added":null,"published":"2017-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["n/a"]},"summary":"A heap-based buffer overflow in UPX allows local attackers to execute arbitrary code or cause denial of service via crafted ELF files.","url":"https://insights.sbomify.com/CVE-2025-2849/"}