CVE-2025-2853 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An authenticated user can cause a denial of service in GitLab due to lack of resource limits, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2853?

CVE-2025-2853 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 22 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. A lack of proper validation in GitLab could allow an authenticated user to cause a denial of service condition.

Weakness: CWE-770

Which versions are affected by CVE-2025-2853?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions17.11.3, 18.0.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-2853?

Upgrade gitlab to a fixed version for your release line: 17.11.3 or 18.0.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-2853 being exploited?

There is no known exploitation of CVE-2025-2853 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-2853, GHSA-crr3-cvh5-8wfr, UBUNTU-CVE-2025-2853.

Is CVE-2025-2853 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free