CVE-2025-2867 Improper Control of Generation of Code ('Code Injection') in GitLab

Medium 4.4 Published Updated

Attackers can manipulate GitLab Duo AI features via crafted issues to expose sensitive project data to unauthorized users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-2867?

CVE-2025-2867 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 27 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in the GitLab Duo with Amazon Q affecting all versions from 17.8 before 17.8.6, 17.9 before 17.9.3, and 17.10 before 17.10.1. A specifically crafted issue could manipulate AI-assisted development features to potentially expose sensitive project data to unauthorized users.

Weakness: CWE-94

Which versions are affected by CVE-2025-2867?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.8.017.8.6, 17.9.3, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-2867?

Upgrade gitlab to a fixed version for your release line: 17.8.6, 17.9.3 or 18.2.2.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2025-2867 being exploited?

There is no known exploitation of CVE-2025-2867 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-2867, GHSA-cxqh-7ch8-jx2g.

Is CVE-2025-2867 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free