CVE-2025-2878 Kentico CMS Additional Database Installation Wizard install.aspx cross site scripting

Medium 4.8 Published Updated

Remote attackers can execute arbitrary scripts via the installation wizard, potentially compromising user sessions or data.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-2878?

CVE-2025-2878 is a medium-severity cross-site scripting vulnerability in Kentico CMS, published on 27 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Kentico CMS up to 13.0.178. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file /CMSInstall/install.aspx of the component Additional Database Installation Wizard. The manipulation of the argument new database leads to cross site scripting. The attack can be launched remotely. Upgrading to version 13.0.179 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2025-2878?

How do I fix CVE-2025-2878?

No fix has been published for CVE-2025-2878 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-2878 being exploited?

There is no known exploitation of CVE-2025-2878 in the wild and no public exploit code.

Sources

Also known as GHSA-7x38-336c-qcwr.

Is CVE-2025-2878 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free