{"answers":{"affected":"3 open source packages ship an affected version, including github.com/NethermindEth/juno. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-29072 in the wild and no public exploit code.","fix":"Upgrade github.com/NethermindEth/juno to 0.12.5 or later.","what":"CVE-2025-29072 is a high-severity vulnerability in n/a, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-29072 and fix it if it is affected.\n\nWhat it is: CVE-2025-29072 is a high-severity vulnerability in n/a, published on 27 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-29072 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/NethermindEth/juno (Go): affected all versions; fixed in 0.12.5\n- github.com/NethermindEth/juno (Go): affected all versions; fixed in 0.12.5\n- github.com/NethermindEth/juno (Go): affected all versions; fixed in 0.12.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29072/ (Markdown: https://insights.sbomify.com/CVE-2025-29072/index.md)","id":"CVE-2025-29072","markdown":"https://insights.sbomify.com/CVE-2025-29072/index.md","name":"CVE-2025-29072","record":{"aliases":["GHSA-wq32-8rp4-w2mc","GO-2025-3583"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Starknet node library","requires_auth":"none","summary":"Remote attackers can cause denial of service in Starknet full nodes via integer overflow in Sierra bytecode decompression, requiring an upgrade to the affected library.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"juno","vendor":"nethermind"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"An integer overflow in Nethermind Juno before v.12.05 within the Sierra bytecode decompression logic within the \"cairo-lang-starknet-classes\" library could allow remote attackers to trigger an infinite loop (and high CPU usage) by submitting a malicious Declare v2/v3 transaction. This results in a denial-of-service condition for affected Starknet full-node implementations.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Nethermind Juno Potential Denial of Service (DoS) via Integer Overflow","id":"CVE-2025-29072","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"SQL injection in n/a","id":"CVE-2025-29083"},"packages":[{"ecosystem":"Go","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"github.com/NethermindEth/juno","purl":null,"source":"GHSA-wq32-8rp4-w2mc"},{"ecosystem":"Go","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"github.com/NethermindEth/juno","purl":"pkg:golang/github.com/NethermindEth/juno","source":"GHSA-wq32-8rp4-w2mc"},{"ecosystem":"Go","fixed":["0.12.5"],"introduced":["0"],"last_affected":[],"package":"github.com/NethermindEth/juno","purl":"pkg:golang/github.com/NethermindEth/juno","source":"GO-2025-3583"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2025-29070"},"products":["n/a"],"published":"2025-03-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-28","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in Starknet full nodes via integer overflow in Sierra bytecode decompression, requiring an upgrade to the affected library.","url":"https://insights.sbomify.com/CVE-2025-29072/"}