CVE-2025-29189 Flowise Vulnerable to SQL Injection via `tableName` Parameter
Attackers can execute arbitrary SQL commands via the tableName parameter in Postgres_VectorStores, potentially reading or modifying database contents.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-29189?
CVE-2025-29189 is a high-severity SQL injection vulnerability in Flowiseai Flowise, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Flowise <= 2.2.3 is vulnerable to SQL Injection. via tableName parameter at Postgres_VectorStores.
Weakness: CWE-89
Which versions are affected by CVE-2025-29189?
2 open source packages ship an affected version, including flowise-components. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise-components npm | All versions | 2.2.4 |
flowise-components npm | All versions | 2.2.4 |
Products include Flowiseai Flowise.
How do I fix CVE-2025-29189?
Upgrade flowise-components to 2.2.4 or later.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2025-29189 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29189 exists.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-gjx9-wg9x-7gvp.