{"answers":{"affected":"2 open source packages ship an affected version, including flowise-components. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29189 exists.","fix":"Upgrade flowise-components to 2.2.4 or later.","what":"CVE-2025-29189 is a high-severity SQL injection vulnerability in Flowiseai Flowise, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-29189 and fix it if it is affected.\n\nWhat it is: CVE-2025-29189 is a high-severity SQL injection vulnerability in Flowiseai Flowise, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29189 exists.\n\nAffected packages and fixed versions:\n- flowise-components (npm): affected all versions; fixed in 2.2.4\n- flowise-components (npm): affected all versions; fixed in 2.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29189/ (Markdown: https://insights.sbomify.com/CVE-2025-29189/index.md)","id":"CVE-2025-29189","markdown":"https://insights.sbomify.com/CVE-2025-29189/index.md","name":"CVE-2025-29189","record":{"aliases":["GHSA-gjx9-wg9x-7gvp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary SQL commands via the tableName parameter in Postgres_VectorStores, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":7.6,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Flowise \u003c= 2.2.3 is vulnerable to SQL Injection. via tableName parameter at Postgres_VectorStores.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise Vulnerable to SQL Injection via `tableName` Parameter","id":"CVE-2025-29189","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"sql_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Flowise Stored XSS vulnerability through logs in chatbot","id":"CVE-2025-29192"},"packages":[{"ecosystem":"npm","fixed":["2.2.4"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":null,"source":"GHSA-gjx9-wg9x-7gvp"},{"ecosystem":"npm","fixed":["2.2.4"],"introduced":["0"],"last_affected":[],"package":"flowise-components","purl":"pkg:npm/flowise-components","source":"GHSA-gjx9-wg9x-7gvp"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2025-29181"},"products":["n/a"],"published":"2025-04-09","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-09","vendors":["n/a"]},"summary":"Attackers can execute arbitrary SQL commands via the tableName parameter in Postgres_VectorStores, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2025-29189/"}