{"answers":{"affected":"2 open source packages ship an affected version, including flowise. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29192 exists.","fix":"Upgrade flowise to 3.0.5 or later.","what":"CVE-2025-29192 is a high-severity cross-site scripting vulnerability in Flowiseai Flowise, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-29192 and fix it if it is affected.\n\nWhat it is: CVE-2025-29192 is a high-severity cross-site scripting vulnerability in Flowiseai Flowise, published on 6 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29192 exists.\n\nAffected packages and fixed versions:\n- flowise (npm): affected all versions; fixed in 3.0.5\n- flowise (npm): affected all versions; fixed in 3.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29192/ (Markdown: https://insights.sbomify.com/CVE-2025-29192/index.md)","id":"CVE-2025-29192","markdown":"https://insights.sbomify.com/CVE-2025-29192/index.md","name":"CVE-2025-29192","record":{"aliases":["GHSA-7r4h-vmj9-wg42"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Flowise AI platform","requires_auth":"none","summary":"Attackers can inject malicious scripts via chat logs that execute when an admin views them, potentially compromising the admin account.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"flowise","vendor":"flowiseai"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Flowise before 3.0.5 allows XSS via a FORM element and an INPUT element when an admin views the chat log.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Flowise Stored XSS vulnerability through logs in chatbot","id":"CVE-2025-29192","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"flowiseai:flowise","products":["flowiseai:flowise"],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"SQL injection in n/a","id":"CVE-2025-29208"},"packages":[{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":null,"source":"GHSA-7r4h-vmj9-wg42"},{"ecosystem":"npm","fixed":["3.0.5"],"introduced":["0"],"last_affected":[],"package":"flowise","purl":"pkg:npm/flowise","source":"GHSA-7r4h-vmj9-wg42"}],"prev":{"headline":"Flowise Vulnerable to SQL Injection via `tableName` Parameter","id":"CVE-2025-29189"},"products":["Flowise"],"published":"2025-10-06","related":[{"cvss_score":10,"headline":"Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API","id":"CVE-2025-71338","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":10,"headline":"Flowise: Authenticated RCE Via MCP Adapters","id":"CVE-2026-40933","kev_date_added":null,"published":"2026-04-21"},{"cvss_score":10,"headline":"Flowise is vulnerable to arbitrary file read, arbitrary file write","id":"CVE-2025-61913","kev_date_added":null,"published":"2025-10-08"},{"cvss_score":10,"headline":"Flowise has Remote Code Execution vulnerability","id":"CVE-2025-59528","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2026-52098","kev_date_added":null,"published":"2026-09-10"},{"cvss_score":9.8,"headline":"Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover","id":"CVE-2025-58434","kev_date_added":null,"published":"2025-09-12"},{"cvss_score":9.8,"headline":"Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers","id":"CVE-2025-8943","kev_date_added":null,"published":"2025-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-06","vendors":["FlowiseAI"]},"summary":"Attackers can inject malicious scripts via chat logs that execute when an admin views them, potentially compromising the admin account.","url":"https://insights.sbomify.com/CVE-2025-29192/"}