CVE-2025-2934 Allocation of Resources Without Limits or Throttling in GitLab

Medium 4.3 Published Updated

An authenticated attacker can cause a denial of service in GitLab by configuring malicious webhook endpoints that send crafted HTTP responses.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2934?

CVE-2025-2934 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 9 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 5.2 prior to 18.2.8, 18.3 prior to 18.3.4, and 18.4 prior to 18.4.2 that could have allowed an authenticated attacker to create a denial of service condition by configuring malicious webhook endpoints that send crafted HTTP responses.

Weakness: CWE-770

Which versions are affected by CVE-2025-2934?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 5.2.018.2.8, 18.3.4, 18.4.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-2934?

Upgrade gitlab to a fixed version for your release line: 18.2.8, 18.3.4 or 18.4.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-2934 being exploited?

There is no known exploitation of CVE-2025-2934 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-2934, GHSA-j56p-cx78-v9ch, UBUNTU-CVE-2025-2934.

Is CVE-2025-2934 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free