CVE-2025-2937 Inefficient Regular Expression Complexity in GitLab

Medium 6.5 Published Updated

Authenticated users can cause a denial of service in GitLab Wiki by sending specially crafted markdown payloads.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2937?

CVE-2025-2937 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 13.2 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that could have allowed authenticated users to create a denial of service condition by sending specially crafted markdown payloads to the Wiki feature.

Weakness: CWE-1333

Which versions are affected by CVE-2025-2937?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 13.2.018.0.6, 18.1.4, 18.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2025-2937?

Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-2937 being exploited?

There is no known exploitation of CVE-2025-2937 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-2937, GHSA-qfpg-mw2p-44hg, MINI-94fh-wmfx-85gp, MINI-h457-qx9v-wjxf, MINI-rh5r-xwmg-5c7m, UBUNTU-CVE-2025-2937.

Is CVE-2025-2937 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free