# CVE-2025-2945: pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment

> Attackers can execute arbitrary code via unsafe eval() calls in pgAdmin 4 Query Tool and Cloud Deployment modules.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-g73c-fw68-pwx3, PYSEC-2026-451

## What is CVE-2025-2945?

CVE-2025-2945 is a critical code injection vulnerability in pgadmin.org pgAdmin 4, published on 3 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Remote Code Execution security vulnerability in pgAdmin 4  (Query Tool and Cloud Deployment modules).

The vulnerability is associated with the 2 POST endpoints; /sqleditor/query_tool/download, where the query_commited parameter and /cloud/deploy endpoint, where the high_availability parameter is unsafely passed to the Python eval() function, allowing arbitrary code execution.

This issue affects pgAdmin 4: before 9.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-2945?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.2 |
| `pgadmin4` | PyPI | All versions | 9.2 |
| `pgadmin4` | PyPI | All versions | 9.2 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2025-2945?

Upgrade pgadmin4 to 9.2 or later.

## Is CVE-2025-2945 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2945 exists.

Public exploit code:

- Python PoC script for pgAdmin4 Query Tool RCE (CVE-2025-2945) (github_poc): https://github.com/Cycloctane/cve-2025-2945-poc
- pgAdmin Proof of Concept (github_poc): https://github.com/abrewer251/CVE-2025-2945_PgAdmin_PoC
- https://github.com/Udayveer17/CVE-2025-2945-pgAdmin4-Authenticated-RCE-PoC- (github_poc): https://github.com/Udayveer17/CVE-2025-2945-pgAdmin4-Authenticated-RCE-PoC-
- pgAdmin Query Tool authenticated RCE (CVE-2025-2945) (metasploit)
- Exploit and test stand for CVE-2025-2945 (github_poc): https://github.com/I3r1h0n/pgAdminOpendoor
- Authenticated RCE in pgAdmin 4 (8.10–9.1) via eval() injection in the Query Tool. This is an updated PoC with compatibility fixes for pgAdmin 9.x auth changes (github_poc): https://github.com/plur1bu5/CVE-2025-2945-pgadmin-rce

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-12045](https://insights.sbomify.com/CVE-2026-12045/): pgAdmin 4: AI Assistant read-only transaction bypass allows unauthorised writes and remote code execution (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2945 and fix it if it is affected.

What it is: CVE-2025-2945 is a critical code injection vulnerability in pgadmin.org pgAdmin 4, published on 3 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2945 exists.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.2
- pgadmin4 (PyPI): affected all versions; fixed in 9.2
- pgadmin4 (PyPI): affected all versions; fixed in 9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2945/ (Markdown: https://insights.sbomify.com/CVE-2025-2945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2945
- OSV: https://osv.dev/vulnerability/CVE-2025-2945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2945/
Summaries are generated and may contain mistakes; the official description above is the record.
