# CVE-2025-29481: Memory corruption in n/a

> A local attacker can execute arbitrary code via a buffer overflow in libbpf when processing untrusted ELF files.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 25 Feb 2026
- **Also known as:** AZL-59719, AZL-59727, AZL-59737, AZL-59745, AZL-61765, BIT-bpftool-2025-29481, DEBIAN-CVE-2025-29481, ECHO-b8d0-8e49-7598, GHSA-3ch3-mpx2-hj74, UBUNTU-CVE-2025-29481

## What is CVE-2025-29481?

CVE-2025-29481 is a medium-severity memory corruption vulnerability in n/a, published on 7 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Buffer Overflow vulnerability in libbpf 1.5.0 allows a local attacker to execute arbitrary code via the bpf_object__init_prog` function of libbpf. This has been disputed by third parties who assert that "no one in their sane mind should be passing untrusted ELF files into libbpf while running under root."

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2025-29481?

1 open source package ship an affected version, including bpftool. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bpftool` | Bitnami | From 1.5.0 | 7.4.0 |

Products: Libbpf Project Libbpf.

## How do I fix CVE-2025-29481?

Upgrade bpftool to 7.4.0 or later.

## Is CVE-2025-29481 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29481 exists.

## Other vulnerabilities in n/a

- [CVE-2021-45940](https://insights.sbomify.com/CVE-2021-45940/): Memory corruption in n/a (medium 6.5)
- [CVE-2021-45941](https://insights.sbomify.com/CVE-2021-45941/): Memory corruption in n/a (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29481 and fix it if it is affected.

What it is: CVE-2025-29481 is a medium-severity memory corruption vulnerability in n/a, published on 7 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29481 exists.

Affected packages and fixed versions:
- bpftool (Bitnami): affected from 1.5.0; fixed in 7.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29481/ (Markdown: https://insights.sbomify.com/CVE-2025-29481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29481
- OSV: https://osv.dev/vulnerability/CVE-2025-29481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29481/
Summaries are generated and may contain mistakes; the official description above is the record.
