CVE-2025-2953 PyTorch torch.mkldnn_max_pool2d denial of service
A local attacker can cause a denial of service in PyTorch via the mkldnn_max_pool2d function, impacting system availability.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-2953?
CVE-2025-2953 is a medium-severity denial of service vulnerability in PyTorch, published on 30 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
A vulnerability, which was classified as problematic, has been found in PyTorch 2.6.0+cu124. Affected by this issue is the function torch.mkldnn_max_pool2d. The manipulation leads to denial of service. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. The security policy of the project warns to use unknown models which might establish malicious effects.
Weakness: CWE-404
Which versions are affected by CVE-2025-2953?
4 open source packages ship an affected version, including pytorch and torch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pytorch Bitnami | From 2.6.0 | 2.7.0 |
torch PyPI | All versions to 2.6.0+cu124 | None |
torch PyPI | All versions | 2.7.1-rc1 |
torch PyPI | All versions | 2.7.1-rc1 |
Products include Linuxfoundation Pytorch.
How do I fix CVE-2025-2953?
Upgrade pytorch to 2.7.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-2953 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2953 exists.
Other vulnerabilities in PyTorch
- CVE-2024-48063 Deserialization in n/a
- CVE-2022-45907 PyTorch vulnerable to arbitrary code execution
- CVE-2025-32434 PyTorch: `torch.load` with `weights_only=True` leads to remote code execution
- CVE-2026-24747 PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files
- CVE-2024-31583 Pytorch use-after-free vulnerability
Sources
Also known as AZL-60913, AZL-60931, BIT-pytorch-2025-2953, DEBIAN-CVE-2025-2953, ECHO-8cc1-2152-8f65, GHSA-3749-ghw9-m3mg and 2 more.