# CVE-2025-29746: Koillection Cross Site Scripting vulnerability

> Remote attackers can exploit Cross-Site Scripting in Koillection to escalate privileges via collection, Wishlist, and album components.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2025
- **Updated:** 8 May 2025
- **Also known as:** GHSA-fxvx-gfmr-5xfj

## What is CVE-2025-29746?

CVE-2025-29746 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting vulnerability in Koillection v.1.6.10 allows a remote attacker to escalate privileges via the collection, Wishlist and album components

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-29746?

2 open source packages ship an affected version, including koillection/koillection. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `koillection/koillection` | Packagist | All versions | 1.6.12 |
| `koillection/koillection` | Packagist | All versions | 1.6.12 |

Products: Benjaminjonard Koillection.

## How do I fix CVE-2025-29746?

Upgrade koillection/koillection to 1.6.12 or later.

## Is CVE-2025-29746 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29746 exists.

## Other vulnerabilities in n/a

- [CVE-2025-9747](https://insights.sbomify.com/CVE-2025-9747/): Koillection csrf_protection_controller.js cross-site request forgery (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29746 and fix it if it is affected.

What it is: CVE-2025-29746 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29746 exists.

Affected packages and fixed versions:
- koillection/koillection (Packagist): affected all versions; fixed in 1.6.12
- koillection/koillection (Packagist): affected all versions; fixed in 1.6.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29746/ (Markdown: https://insights.sbomify.com/CVE-2025-29746/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29746
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29746
- OSV: https://osv.dev/vulnerability/CVE-2025-29746

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29746/
Summaries are generated and may contain mistakes; the official description above is the record.
