# CVE-2025-29770: vLLM denial of service via outlines unbounded cache on disk

> Attackers can cause denial of service in vLLM by exhausting disk space through unbounded caching of unique schemas in the outlines backend.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-mgrm-fgjv-mhv8, PYSEC-2025-223

## What is CVE-2025-29770?

CVE-2025-29770 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 19 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. The outlines library is one of the backends used by vLLM to support structured output (a.k.a. guided decoding). Outlines provides an optional cache for its compiled grammars on the local filesystem. This cache has been on by default in vLLM. Outlines is also available by default through the OpenAI compatible API server. The affected code in vLLM is vllm/model_executor/guided_decoding/outlines_logits_processors.py, which unconditionally uses the cache from outlines. A malicious user can send a stream of very short decoding requests with unique schemas, resulting in an addition to the cache for each request. This can result in a Denial of Service if the filesystem runs out of space. Note that even if vLLM was configured to use a different backend by default, it is still possible to choose outlines on a per-request basis using the guided_decoding_backend key of the extra_body field of the request. This issue applies only to the V0 engine and is fixed in 0.8.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-29770?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.8.0 |
| `vllm` | PyPI | All versions | 0.8.0 |
| `vllm` | PyPI | All versions | 0.8.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-29770?

Upgrade vllm to 0.8.0 or later.

## Is CVE-2025-29770 being exploited?

There is no known exploitation of CVE-2025-29770 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29770 and fix it if it is affected.

What it is: CVE-2025-29770 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 19 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-29770 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.8.0
- vllm (PyPI): affected all versions; fixed in 0.8.0
- vllm (PyPI): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29770/ (Markdown: https://insights.sbomify.com/CVE-2025-29770/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29770
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29770
- OSV: https://osv.dev/vulnerability/CVE-2025-29770

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29770/
Summaries are generated and may contain mistakes; the official description above is the record.
