# CVE-2025-29771: HtmlSanitizer vulnerable to XSS when used with contentEditable

> Attackers can execute arbitrary scripts via XSS when HtmlSanitizer is used with contentEditable elements due to post-sanitization beautification flaws.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2025
- **Updated:** 18 Mar 2025
- **Also known as:** GHSA-vhv4-fh94-jm5x

## What is CVE-2025-29771?

CVE-2025-29771 is a medium-severity cross-site scripting vulnerability in jitbit HtmlSanitizer, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HtmlSanitizer is a client-side HTML Sanitizer. Versions prior to 2.0.3 have a cross-site scripting vulnerability when the sanitizer is used with a `contentEditable` element to set the elements `innerHTML` to a sanitized string produced by the package. If the code is particularly crafted to abuse the code beautifier, that runs AFTER sanitation. The issue is patched in version 2.0.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-29771?

2 open source packages ship an affected version, including @jitbit/htmlsanitizer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@jitbit/htmlsanitizer` | npm | All versions | 2.0.3 |
| `@jitbit/htmlsanitizer` | npm | All versions | 2.0.3 |

## How do I fix CVE-2025-29771?

Upgrade @jitbit/htmlsanitizer to 2.0.3 or later.

## Is CVE-2025-29771 being exploited?

There is no known exploitation of CVE-2025-29771 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29771 and fix it if it is affected.

What it is: CVE-2025-29771 is a medium-severity cross-site scripting vulnerability in jitbit HtmlSanitizer, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-29771 in the wild and no public exploit code.

Affected packages and fixed versions:
- @jitbit/htmlsanitizer (npm): affected all versions; fixed in 2.0.3
- @jitbit/htmlsanitizer (npm): affected all versions; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29771/ (Markdown: https://insights.sbomify.com/CVE-2025-29771/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29771
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29771
- OSV: https://osv.dev/vulnerability/CVE-2025-29771

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29771/
Summaries are generated and may contain mistakes; the official description above is the record.
