# CVE-2025-29773: Froxlor allows Multiple Accounts to Share the Same Email Address Leading to Potential Privilege Escalation or Account Takeover

> Authenticated users can create accounts with duplicate email addresses, potentially leading to privilege escalation or account takeover in Froxlor.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2025
- **Updated:** 13 Mar 2025
- **Also known as:** GHSA-7j6w-p859-464f

## What is CVE-2025-29773?

CVE-2025-29773 is a medium-severity vulnerability in Froxlor, published on 13 Mar 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Froxlor is open-source server administration software. A vulnerability in versions prior to 2.2.6 allows users (such as resellers or customers) to create accounts with the same email address as an existing account. This creates potential issues with account identification and security. This vulnerability can be exploited by authenticated users (e.g., reseller, customer) who can create accounts with the same email address that has already been used by another account, such as the admin. The attack vector is email-based, as the system does not prevent multiple accounts from registering the same email address, leading to possible conflicts and security issues. Version 2.2.6 fixes the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-29773?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.2.6 |
| `froxlor/froxlor` | Packagist | All versions | 2.2.6 |

Products: Froxlor Froxlor.

## How do I fix CVE-2025-29773?

Upgrade froxlor/froxlor to 2.2.6 or later.

## Is CVE-2025-29773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29773 exists.

## Other vulnerabilities in Froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29773 and fix it if it is affected.

What it is: CVE-2025-29773 is a medium-severity vulnerability in Froxlor, published on 13 Mar 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29773 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.2.6
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29773/ (Markdown: https://insights.sbomify.com/CVE-2025-29773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29773
- OSV: https://osv.dev/vulnerability/CVE-2025-29773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29773/
Summaries are generated and may contain mistakes; the official description above is the record.
