CVE-2025-29774 xml-crypto Vulnerable to XML Signature Verification Bypass via Multiple SignedInfo References

Critical 9.3 Published Updated

Attackers can bypass XML signature verification to modify signed messages, enabling privilege escalation or user impersonation in systems using xml-crypto.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-29774?

CVE-2025-29774 is a critical vulnerability in node-saml xml-crypto, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

xml-crypto is an XML digital signature and encryption library for Node.js. An attacker may be able to exploit a vulnerability in versions prior to 6.0.1, 3.2.1, and 2.1.6 to bypass authentication or authorization mechanisms in systems that rely on xml-crypto for verifying signed XML documents. The vulnerability allows an attacker to modify a valid signed XML message in a way that still passes signature verification checks. For example, it could be used to alter critical identity or access control attributes, enabling an attacker with a valid account to escalate privileges or impersonate another user. Users of versions 6.0.0 and prior should upgrade to version 6.0.1 to receive a fix. Those who are still using v2.x or v3.x should upgrade to patched versions 2.1.6 or 3.2.1, respectively.

Weakness: CWE-347

Which versions are affected by CVE-2025-29774?

6 open source packages ship an affected version, including xml-crypto.

PackageAffectedFixed in
xml-crypto npmAll versions2.1.6
xml-crypto npmAll versions2.1.6
xml-crypto npmFrom 3.0.03.2.1
xml-crypto npmFrom 3.0.03.2.1
xml-crypto npmFrom 4.0.06.0.1
xml-crypto npmFrom 4.0.06.0.1

How do I fix CVE-2025-29774?

Upgrade xml-crypto to a fixed version for your release line: 2.1.6, 3.2.1 or 6.0.1.

Is CVE-2025-29774 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29774 exists.

Public exploit code: 2 proofs of concept on GitHub.

Sources

Also known as GHSA-9p8x-f768-wp2g.

Is CVE-2025-29774 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free