{"answers":{"affected":"6 open source packages ship an affected version, including xml-crypto.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29775 exists.","fix":"Upgrade xml-crypto to a fixed version for your release line: 2.1.6, 3.2.1 or 6.0.1.","what":"CVE-2025-29775 is a critical vulnerability in node-saml xml-crypto, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-29775 and fix it if it is affected.\n\nWhat it is: CVE-2025-29775 is a critical vulnerability in node-saml xml-crypto, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29775 exists.\n\nAffected packages and fixed versions:\n- xml-crypto (npm): affected all versions; fixed in 2.1.6\n- xml-crypto (npm): affected all versions; fixed in 2.1.6\n- xml-crypto (npm): affected from 3.0.0; fixed in 3.2.1\n- xml-crypto (npm): affected from 3.0.0; fixed in 3.2.1\n- xml-crypto (npm): affected from 4.0.0; fixed in 6.0.1\n- xml-crypto (npm): affected from 4.0.0; fixed in 6.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29775/ (Markdown: https://insights.sbomify.com/CVE-2025-29775/index.md)","id":"CVE-2025-29775","markdown":"https://insights.sbomify.com/CVE-2025-29775/index.md","name":"CVE-2025-29775","record":{"aliases":["GHSA-x3m8-899r-f7c3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js XML crypto library","requires_auth":"none","summary":"Attackers can bypass XML signature verification to modify signed messages, enabling privilege escalation or user impersonation in systems using xml-crypto.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"xml-crypto is an XML digital signature and encryption library for Node.js. An attacker may be able to exploit a vulnerability in versions prior to 6.0.1, 3.2.1, and 2.1.6 to bypass authentication or authorization mechanisms in systems that rely on xml-crypto for verifying signed XML documents. The vulnerability allows an attacker to modify a valid signed XML message in a way that still passes signature verification checks. For example, it could be used to alter critical identity or access control attributes, enabling an attacker to escalate privileges or impersonate another user. Users of versions 6.0.0 and prior should upgrade to version 6.0.1 to receive a fix. Those who are still using v2.x or v3.x should upgrade to patched versions 2.1.6 or 3.2.1, respectively.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-04-17","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-04-17T02:32:30Z","kind":"github_poc","ref":"https://github.com/ethicalPap/CVE-2025-29775","stars":1,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"xml-crypto Vulnerable to XML Signature Verification Bypass via DigestValue Comment","id":"CVE-2025-29775","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":6,"n_references":7,"next":{"headline":"Azle calling `setTimer` causes infinite loop of timers","id":"CVE-2025-29776"},"packages":[{"ecosystem":"npm","fixed":["2.1.6"],"introduced":["0"],"last_affected":[],"package":"xml-crypto","purl":null,"source":"GHSA-x3m8-899r-f7c3"},{"ecosystem":"npm","fixed":["2.1.6"],"introduced":["0"],"last_affected":[],"package":"xml-crypto","purl":"pkg:npm/xml-crypto","source":"GHSA-x3m8-899r-f7c3"},{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["3.0.0"],"last_affected":[],"package":"xml-crypto","purl":null,"source":"GHSA-x3m8-899r-f7c3"},{"ecosystem":"npm","fixed":["3.2.1"],"introduced":["3.0.0"],"last_affected":[],"package":"xml-crypto","purl":"pkg:npm/xml-crypto","source":"GHSA-x3m8-899r-f7c3"},{"ecosystem":"npm","fixed":["6.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"xml-crypto","purl":null,"source":"GHSA-x3m8-899r-f7c3"},{"ecosystem":"npm","fixed":["6.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"xml-crypto","purl":"pkg:npm/xml-crypto","source":"GHSA-x3m8-899r-f7c3"}],"prev":{"headline":"xml-crypto Vulnerable to XML Signature Verification Bypass via Multiple SignedInfo References","id":"CVE-2025-29774"},"products":["xml-crypto"],"published":"2025-03-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-15","vendors":["node-saml"]},"summary":"Attackers can bypass XML signature verification to modify signed messages, enabling privilege escalation or user impersonation in systems using xml-crypto.","url":"https://insights.sbomify.com/CVE-2025-29775/"}