CVE-2025-29776 Azle calling `setTimer` causes infinite loop of timers
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-29776?
CVE-2025-29776 is a high-severity vulnerability in demergent-labs azle, published on 14 Mar 2025.
Official description
Azle is a WebAssembly runtime for TypeScript and JavaScript on ICP. Calling `setTimer` in Azle versions `0.27.0`, `0.28.0`, and `0.29.0` causes an immediate infinite loop of timers to be executed on the canister, each timer attempting to clean up the global state of the previous timer. The infinite loop will occur with any valid invocation of `setTimer`. The problem has been fixed as of Azle version `0.30.0`. As a workaround, if a canister is caught in this infinite loop after calling `setTimer`, the canister can be upgraded and the timers will all be cleared, thus ending the loop.
Weakness: CWE-835
Which versions are affected by CVE-2025-29776?
2 open source packages ship an affected version, including azle.
| Package | Affected | Fixed in |
|---|---|---|
azle npm | From 0.27.0 | 0.30.0 |
azle npm | From 0.27.0 | 0.30.0 |
How do I fix CVE-2025-29776?
Upgrade azle to 0.30.0 or later.
Is CVE-2025-29776 being exploited?
There is no known exploitation of CVE-2025-29776 in the wild and no public exploit code.
Sources
Also known as GHSA-xc76-5pf9-mx8m.