# CVE-2025-29778: Kyverno ignores subjectRegExp and IssuerRegExp

> Kyverno fails to validate certificate subject and issuer regexes in keyless mode, allowing attackers to deploy unauthorized resources and compromise the cluster.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2025
- **Updated:** 24 Mar 2025
- **Also known as:** BIT-kyverno-2025-29778, GHSA-46mp-8w32-6g94, GO-2025-3562, MINI-3gmf-mx96-c8fv, MINI-3m24-pc86-v9x5, MINI-95qh-8v3j-mc4m, MINI-prjq-27j5-qgvw, MINI-rpmx-cf7f-vcgj

## What is CVE-2025-29778?

CVE-2025-29778 is a medium-severity authentication bypass vulnerability in kyverno, published on 24 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. Prior to version 1.14.0-alpha.1, Kyverno ignores subjectRegExp and IssuerRegExp while verifying artifact's sign with keyless mode. It allows the attacker to deploy kubernetes resources with the artifacts that were signed by unexpected certificate. Deploying these unauthorized kubernetes resources can lead to full compromise of kubernetes cluster. Version 1.14.0-alpha.1 contains a patch for the issue.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-29778?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | 1.14.0-alpha.1 |
| `github.com/kyverno/kyverno` | Go | From 1.13.0 | 1.14.0-alpha.1 |
| `github.com/kyverno/kyverno` | Go | From 1.13.0 | 1.14.0-alpha.1 |
| `kyverno` | Bitnami | All versions | 1.14.0 |

Products: Kyverno Kyverno.

## How do I fix CVE-2025-29778?

Upgrade github.com/kyverno/kyverno to 1.14.0-alpha.1 or later.

## Is CVE-2025-29778 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29778 exists.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29778 and fix it if it is affected.

What it is: CVE-2025-29778 is a medium-severity authentication bypass vulnerability in kyverno, published on 24 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29778 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; fixed in 1.14.0-alpha.1
- github.com/kyverno/kyverno (Go): affected from 1.13.0; fixed in 1.14.0-alpha.1
- github.com/kyverno/kyverno (Go): affected from 1.13.0; fixed in 1.14.0-alpha.1
- kyverno (Bitnami): affected all versions; fixed in 1.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29778/ (Markdown: https://insights.sbomify.com/CVE-2025-29778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29778
- OSV: https://osv.dev/vulnerability/CVE-2025-29778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29778/
Summaries are generated and may contain mistakes; the official description above is the record.
