CVE-2025-29783 vLLM Allows Remote Code Execution via Mooncake Integration

Critical 9.1 Published Updated

Attackers can execute remote code on distributed hosts if vLLM is configured with Mooncake, due to unsafe deserialization over ZMQ/TCP.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-29783?

CVE-2025-29783 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 19 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.

Weakness: CWE-502

Which versions are affected by CVE-2025-29783?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.6.50.8.0
vllm PyPIFrom 0.6.50.8.0
vllm PyPIFrom 0.6.50.8.0

Products include Vllm Vllm.

How do I fix CVE-2025-29783?

Upgrade vllm to 0.8.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-29783 being exploited?

There is no known exploitation of CVE-2025-29783 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-x3m8-f7g5-qhm7, PYSEC-2025-63.

Is CVE-2025-29783 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free