{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-29783 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.8.0 or later.","what":"CVE-2025-29783 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 19 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-29783 and fix it if it is affected.\n\nWhat it is: CVE-2025-29783 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 19 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-29783 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.6.5; fixed in 0.8.0\n- vllm (PyPI): affected from 0.6.5; fixed in 0.8.0\n- vllm (PyPI): affected from 0.6.5; fixed in 0.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29783/ (Markdown: https://insights.sbomify.com/CVE-2025-29783/index.md)","id":"CVE-2025-29783","markdown":"https://insights.sbomify.com/CVE-2025-29783/index.md","name":"CVE-2025-29783","record":{"aliases":["GHSA-x3m8-f7g5-qhm7","PYSEC-2025-63"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"LLM inference engine","requires_auth":"low_privilege","summary":"Attackers can execute remote code on distributed hosts if vLLM is configured with Mooncake, due to unsafe deserialization over ZMQ/TCP.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"NamelessMC Has Lack of Length Validation for s Parameter in GET Requests","id":"CVE-2025-29784"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.0"],"introduced":["0.6.5"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-x3m8-f7g5-qhm7"},{"ecosystem":"PyPI","fixed":["0.8.0"],"introduced":["0.6.5"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-x3m8-f7g5-qhm7"},{"ecosystem":"PyPI","fixed":["0.8.0"],"introduced":["0.6.5"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2025-63"}],"prev":{"headline":"WeGIA Cross-Site Scripting (XSS) Stored in endpoint `adicionar_tipo_docs_atendido.php` parameter `tipo`","id":"CVE-2025-29782"},"products":["vllm"],"published":"2025-03-19","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-22","vendors":["vllm-project"]},"summary":"Attackers can execute remote code on distributed hosts if vLLM is configured with Mooncake, due to unsafe deserialization over ZMQ/TCP.","url":"https://insights.sbomify.com/CVE-2025-29783/"}