# CVE-2025-29783: vLLM Allows Remote Code Execution via Mooncake Integration

> Attackers can execute remote code on distributed hosts if vLLM is configured with Mooncake, due to unsafe deserialization over ZMQ/TCP.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2025
- **Updated:** 22 Mar 2025
- **Also known as:** GHSA-x3m8-f7g5-qhm7, PYSEC-2025-63

## What is CVE-2025-29783?

CVE-2025-29783 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 19 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-29783?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.6.5 | 0.8.0 |
| `vllm` | PyPI | From 0.6.5 | 0.8.0 |
| `vllm` | PyPI | From 0.6.5 | 0.8.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-29783?

Upgrade vllm to 0.8.0 or later.

## Is CVE-2025-29783 being exploited?

There is no known exploitation of CVE-2025-29783 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29783 and fix it if it is affected.

What it is: CVE-2025-29783 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 19 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-29783 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.6.5; fixed in 0.8.0
- vllm (PyPI): affected from 0.6.5; fixed in 0.8.0
- vllm (PyPI): affected from 0.6.5; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29783/ (Markdown: https://insights.sbomify.com/CVE-2025-29783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29783
- OSV: https://osv.dev/vulnerability/CVE-2025-29783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29783/
Summaries are generated and may contain mistakes; the official description above is the record.
