{"answers":{"affected":"3 open source packages ship an affected version, including github.com/expr-lang/expr.","exploited":"There is no known exploitation of CVE-2025-29786 in the wild and no public exploit code.","fix":"Upgrade github.com/expr-lang/expr to 1.17.0 or later.","what":"CVE-2025-29786 is a high-severity denial of service vulnerability in expr-lang expr, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-29786 and fix it if it is affected.\n\nWhat it is: CVE-2025-29786 is a high-severity denial of service vulnerability in expr-lang expr, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-29786 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/expr-lang/expr (Go): affected all versions; fixed in 1.17.0\n- github.com/expr-lang/expr (Go): affected all versions; fixed in 1.17.0\n- github.com/expr-lang/expr (Go): affected all versions; fixed in 1.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29786/ (Markdown: https://insights.sbomify.com/CVE-2025-29786/index.md)","id":"CVE-2025-29786","markdown":"https://insights.sbomify.com/CVE-2025-29786/index.md","name":"CVE-2025-29786","record":{"aliases":["AZL-58848","AZL-58857","AZL-58861","AZL-58872","CLEANSTART-2026-AX88434","CLEANSTART-2026-QQ38199","DEBIAN-CVE-2025-29786","GHSA-93mq-9ffx-83m2","GO-2025-3525","MINI-2rmm-m4m6-qpmq","MINI-37jh-p8jq-9385","MINI-39cq-5p5f-mh69","MINI-3x77-26xq-g638","MINI-6gc2-w3c8-rvh9","MINI-6vxp-phjc-hrrm","MINI-77fj-9gw3-pqqp","MINI-8vw9-jccc-xgmh","MINI-p9qx-39fw-jjpx","ROOT-APP-GOBINARY-CVE-2025-29786","UBUNTU-CVE-2025-29786","openSUSE-SU-2025:15006-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Go expression library","requires_auth":"none","summary":"Attackers can cause denial of service via memory exhaustion by submitting unbounded input to the Expr parser, requiring input size restrictions or an upgrade.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Expr is an expression language and expression evaluation for Go. Prior to version 1.17.0, if the Expr expression parser is given an unbounded input string, it will attempt to compile the entire string and generate an Abstract Syntax Tree (AST) node for each part of the expression. In scenarios where input size isn’t limited, a malicious or inadvertent extremely large expression can consume excessive memory as the parser builds a huge AST. This can ultimately lead to*excessive memory usage and an Out-Of-Memory (OOM) crash of the process. This issue is relatively uncommon and will only manifest when there are no restrictions on the input size, i.e. the expression length is allowed to grow arbitrarily large. In typical use cases where inputs are bounded or validated, this problem would not occur. The problem has been patched in the latest versions of the Expr library. The fix introduces compile-time limits on the number of AST nodes and memory usage during parsing, preventing any single expression from exhausting resources. Users should upgrade to Expr version 1.17.0 or later, as this release includes the new node budget and memory limit safeguards. Upgrading to v1.17.0 ensures that extremely deep or large expressions are detected and safely aborted during compilation, avoiding the OOM condition. For users who cannot immediately upgrade, the recommended workaround is to impose an input size restriction before parsing. In practice, this means validating or limiting the length of expression strings that your application will accept. For example, set a maximum allowable number of characters (or nodes) for any expression and reject or truncate inputs that exceed this limit. By ensuring no unbounded-length expression is ever fed into the parser, one can prevent the parser from constructing a pathologically large AST and avoid potential memory exhaustion. In short, pre-validate and cap input size as a safeguard in the absence of the patch.","ecosystems":["Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory Exhaustion in Expr Parser with Unrestricted Input","id":"CVE-2025-29786","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"zip Vulnerable to Incorrect Path Canonicalization During Archive Extraction, Leading to Arbitrary File Write","id":"CVE-2025-29787"},"packages":[{"ecosystem":"Go","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"github.com/expr-lang/expr","purl":null,"source":"GHSA-93mq-9ffx-83m2"},{"ecosystem":"Go","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"github.com/expr-lang/expr","purl":"pkg:golang/github.com/expr-lang/expr","source":"GHSA-93mq-9ffx-83m2"},{"ecosystem":"Go","fixed":["1.17.0"],"introduced":["0"],"last_affected":[],"package":"github.com/expr-lang/expr","purl":"pkg:golang/github.com/expr-lang/expr","source":"GO-2025-3525"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.14.10-1.1"],"introduced":["0"],"last_affected":[],"package":"argocd-cli","purl":"pkg:rpm/opensuse/argocd-cli\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15006-1"}],"prev":{"headline":"quic-go Has Panic in Path Probe Loss Recovery Handling","id":"CVE-2025-29785"},"products":["expr"],"published":"2025-03-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-23","vendors":["expr-lang"]},"summary":"Attackers can cause denial of service via memory exhaustion by submitting unbounded input to the Expr parser, requiring input size restrictions or an upgrade.","url":"https://insights.sbomify.com/CVE-2025-29786/"}