# CVE-2025-29786: Memory Exhaustion in Expr Parser with Unrestricted Input

> Attackers can cause denial of service via memory exhaustion by submitting unbounded input to the Expr parser, requiring input size restrictions or an upgrade.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2025
- **Updated:** 23 Jan 2026
- **Also known as:** AZL-58848, AZL-58857, AZL-58861, AZL-58872, CLEANSTART-2026-AX88434, CLEANSTART-2026-QQ38199, DEBIAN-CVE-2025-29786, GHSA-93mq-9ffx-83m2, GO-2025-3525, MINI-2rmm-m4m6-qpmq, MINI-37jh-p8jq-9385, MINI-39cq-5p5f-mh69, MINI-3x77-26xq-g638, MINI-6gc2-w3c8-rvh9, MINI-6vxp-phjc-hrrm, MINI-77fj-9gw3-pqqp, MINI-8vw9-jccc-xgmh, MINI-p9qx-39fw-jjpx, ROOT-APP-GOBINARY-CVE-2025-29786, UBUNTU-CVE-2025-29786, openSUSE-SU-2025:15006-1

## What is CVE-2025-29786?

CVE-2025-29786 is a high-severity denial of service vulnerability in expr-lang expr, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Expr is an expression language and expression evaluation for Go. Prior to version 1.17.0, if the Expr expression parser is given an unbounded input string, it will attempt to compile the entire string and generate an Abstract Syntax Tree (AST) node for each part of the expression. In scenarios where input size isn’t limited, a malicious or inadvertent extremely large expression can consume excessive memory as the parser builds a huge AST. This can ultimately lead to*excessive memory usage and an Out-Of-Memory (OOM) crash of the process. This issue is relatively uncommon and will only manifest when there are no restrictions on the input size, i.e. the expression length is allowed to grow arbitrarily large. In typical use cases where inputs are bounded or validated, this problem would not occur. The problem has been patched in the latest versions of the Expr library. The fix introduces compile-time limits on the number of AST nodes and memory usage during parsing, preventing any single expression from exhausting resources. Users should upgrade to Expr version 1.17.0 or later, as this release includes the new node budget and memory limit safeguards. Upgrading to v1.17.0 ensures that extremely deep or large expressions are detected and safely aborted during compilation, avoiding the OOM condition. For users who cannot immediately upgrade, the recommended workaround is to impose an input size restriction before parsing. In practice, this means validating or limiting the length of expression strings that your application will accept. For example, set a maximum allowable number of characters (or nodes) for any expression and reject or truncate inputs that exceed this limit. By ensuring no unbounded-length expression is ever fed into the parser, one can prevent the parser from constructing a pathologically large AST and avoid potential memory exhaustion. In short, pre-validate and cap input size as a safeguard in the absence of the patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-29786?

3 open source packages ship an affected version, including github.com/expr-lang/expr.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/expr-lang/expr` | Go | All versions | 1.17.0 |
| `github.com/expr-lang/expr` | Go | All versions | 1.17.0 |
| `github.com/expr-lang/expr` | Go | All versions | 1.17.0 |
| `argocd-cli` | openSUSE:Tumbleweed | All versions | 2.14.10-1.1 |

## How do I fix CVE-2025-29786?

Upgrade github.com/expr-lang/expr to 1.17.0 or later.

## Is CVE-2025-29786 being exploited?

There is no known exploitation of CVE-2025-29786 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29786 and fix it if it is affected.

What it is: CVE-2025-29786 is a high-severity denial of service vulnerability in expr-lang expr, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-29786 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/expr-lang/expr (Go): affected all versions; fixed in 1.17.0
- github.com/expr-lang/expr (Go): affected all versions; fixed in 1.17.0
- github.com/expr-lang/expr (Go): affected all versions; fixed in 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29786/ (Markdown: https://insights.sbomify.com/CVE-2025-29786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29786
- OSV: https://osv.dev/vulnerability/CVE-2025-29786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29786/
Summaries are generated and may contain mistakes; the official description above is the record.
