CVE-2025-29788 Sylius PayPal Plugin Payment Amount Manipulation Vulnerability
Attackers can manipulate cart quantities after checkout initiation to pay less than the actual order value, causing financial loss for merchants.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-29788?
CVE-2025-29788 is a medium-severity vulnerability in Sylius PayPalPlugin, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. A vulnerability in versions prior to 1.6.1, 1.7.1, and 2.0.1 allows users to manipulate the final payment amount processed by PayPal. If a user modifies the item quantity in their shopping cart after initiating the PayPal Express Checkout process, PayPal will not receive the updated total amount. As a result, PayPal captures only the initially transmitted amount, while Sylius incorrectly considers the order fully paid based on the modified total. This flaw can be exploited both accidentally and intentionally, potentially enabling fraud by allowing customers to pay less than the actual order value. Attackers can intentionally pay less than the actual total order amount, business owners may suffer financial losses due to underpaid orders, and integrity of payment processing is compromised. The issue is fixed in versions 1.6.1, 1.7.1, 2.0.1, and above. To resolve the problem in the end application without updating to the newest patches, there is a need to overwrite `ProcessPayPalOrderAction`, `CompletePayPalOrderFromPaymentPageAction`, and `CaptureAction` with modified logic.
Weakness: CWE-472
Which versions are affected by CVE-2025-29788?
6 open source packages ship an affected version, including sylius/paypal-plugin.
| Package | Affected | Fixed in |
|---|---|---|
sylius/paypal-plugin Packagist | All versions | 1.6.1 |
sylius/paypal-plugin Packagist | All versions | 1.6.1 |
sylius/paypal-plugin Packagist | From 1.7.0 | 1.7.1 |
sylius/paypal-plugin Packagist | From 1.7.0 | 1.7.1 |
sylius/paypal-plugin Packagist | From 2.0.0 | 2.0.1 |
sylius/paypal-plugin Packagist | From 2.0.0 | 2.0.1 |
How do I fix CVE-2025-29788?
Upgrade sylius/paypal-plugin to a fixed version for your release line: 1.6.1, 1.7.1 or 2.0.1.
Is CVE-2025-29788 being exploited?
There is no known exploitation of CVE-2025-29788 in the wild and no public exploit code.
Sources
Also known as GHSA-pqq3-q84h-pj6x.