{"answers":{"affected":"6 open source packages ship an affected version, including sylius/paypal-plugin.","exploited":"There is no known exploitation of CVE-2025-29788 in the wild and no public exploit code.","fix":"Upgrade sylius/paypal-plugin to a fixed version for your release line: 1.6.1, 1.7.1 or 2.0.1.","what":"CVE-2025-29788 is a medium-severity vulnerability in Sylius PayPalPlugin, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-29788 and fix it if it is affected.\n\nWhat it is: CVE-2025-29788 is a medium-severity vulnerability in Sylius PayPalPlugin, published on 17 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-29788 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sylius/paypal-plugin (Packagist): affected all versions; fixed in 1.6.1\n- sylius/paypal-plugin (Packagist): affected all versions; fixed in 1.6.1\n- sylius/paypal-plugin (Packagist): affected from 1.7.0; fixed in 1.7.1\n- sylius/paypal-plugin (Packagist): affected from 1.7.0; fixed in 1.7.1\n- sylius/paypal-plugin (Packagist): affected from 2.0.0; fixed in 2.0.1\n- sylius/paypal-plugin (Packagist): affected from 2.0.0; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-29788/ (Markdown: https://insights.sbomify.com/CVE-2025-29788/index.md)","id":"CVE-2025-29788","markdown":"https://insights.sbomify.com/CVE-2025-29788/index.md","name":"CVE-2025-29788","record":{"aliases":["GHSA-pqq3-q84h-pj6x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Sylius PayPal plugin","requires_auth":"none","summary":"Attackers can manipulate cart quantities after checkout initiation to pay less than the actual order value, causing financial loss for merchants.","user_interaction":"required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-472","name":"External Control of Assumed-Immutable Web Parameter"}],"description":"The Syliud PayPal Plugin is the Sylius Core Team’s plugin for the PayPal Commerce Platform. A vulnerability in versions prior to 1.6.1, 1.7.1, and 2.0.1 allows users to manipulate the final payment amount processed by PayPal. If a user modifies the item quantity in their shopping cart after initiating the PayPal Express Checkout process, PayPal will not receive the updated total amount. As a result, PayPal captures only the initially transmitted amount, while Sylius incorrectly considers the order fully paid based on the modified total. This flaw can be exploited both accidentally and intentionally, potentially enabling fraud by allowing customers to pay less than the actual order value. Attackers can intentionally pay less than the actual total order amount, business owners may suffer financial losses due to underpaid orders, and integrity of payment processing is compromised. The issue is fixed in versions 1.6.1, 1.7.1, 2.0.1, and above. To resolve the problem in the end application without updating to the newest patches, there is a need to overwrite `ProcessPayPalOrderAction`, `CompletePayPalOrderFromPaymentPageAction`, and `CaptureAction` with modified logic.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sylius PayPal Plugin Payment Amount Manipulation Vulnerability","id":"CVE-2025-29788","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2025"},"n_packages":6,"n_references":6,"next":{"headline":"OpenEMR Has Directory Traversal in Load Code feature","id":"CVE-2025-29789"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"sylius/paypal-plugin","purl":null,"source":"GHSA-pqq3-q84h-pj6x"},{"ecosystem":"Packagist","fixed":["1.6.1"],"introduced":["0"],"last_affected":[],"package":"sylius/paypal-plugin","purl":"pkg:composer/sylius/paypal-plugin","source":"GHSA-pqq3-q84h-pj6x"},{"ecosystem":"Packagist","fixed":["1.7.1"],"introduced":["1.7.0"],"last_affected":[],"package":"sylius/paypal-plugin","purl":null,"source":"GHSA-pqq3-q84h-pj6x"},{"ecosystem":"Packagist","fixed":["1.7.1"],"introduced":["1.7.0"],"last_affected":[],"package":"sylius/paypal-plugin","purl":"pkg:composer/sylius/paypal-plugin","source":"GHSA-pqq3-q84h-pj6x"},{"ecosystem":"Packagist","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"sylius/paypal-plugin","purl":null,"source":"GHSA-pqq3-q84h-pj6x"},{"ecosystem":"Packagist","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"sylius/paypal-plugin","purl":"pkg:composer/sylius/paypal-plugin","source":"GHSA-pqq3-q84h-pj6x"}],"prev":{"headline":"zip Vulnerable to Incorrect Path Canonicalization During Archive Extraction, Leading to Arbitrary File Write","id":"CVE-2025-29787"},"products":["PayPalPlugin"],"published":"2025-03-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-17","vendors":["Sylius"]},"summary":"Attackers can manipulate cart quantities after checkout initiation to pay less than the actual order value, causing financial loss for merchants.","url":"https://insights.sbomify.com/CVE-2025-29788/"}