# CVE-2025-29847: Apache Linkis: Arbitrary File Read via Double URL Encoding Bypass

> Attackers can read arbitrary system files by bypassing URL encoding checks in JDBC parameters, affecting Apache Linkis users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-c399-q49h-qwc8

## What is CVE-2025-29847?

CVE-2025-29847 is a high-severity path traversal vulnerability in Apache Linkis, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in Apache Linkis.

Problem Description
When using the JDBC engine and da
When using the JDBC engine and data source functionality, if the URL parameter configured on the frontend has undergone multiple rounds of URL encoding, it may bypass the system's checks. This bypass can trigger a vulnerability that allows unauthorized access to system files via JDBC parameters.

Scope of Impact

This issue affects Apache Linkis: from 1.3.0 through 1.7.0.

Severity level

moderate
Solution
Continuously check if the connection information contains the "%" character; if it does, perform URL decoding.

Users are recommended to upgrade to version 1.8.0, which fixes the issue.

More questions about this vulnerability can be discussed here:  https://lists.apache.org/list?dev@linkis.apache.org:2025-9:cve

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-29847?

2 open source packages ship an affected version, including org.apache.linkis:linkis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis` | Maven | From 1.3.0 | 1.8.0 |
| `org.apache.linkis:linkis` | Maven | From 1.3.0 | 1.8.0 |

Products: Apache Linkis.

## How do I fix CVE-2025-29847?

Upgrade org.apache.linkis:linkis to 1.8.0 or later.

## Is CVE-2025-29847 being exploited?

There is no known exploitation of CVE-2025-29847 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29215](https://insights.sbomify.com/CVE-2023-29215/): Apache Linkis JDBC EngineCon has a deserialization command execution (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29847 and fix it if it is affected.

What it is: CVE-2025-29847 is a high-severity path traversal vulnerability in Apache Linkis, published on 19 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-29847 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis (Maven): affected from 1.3.0; fixed in 1.8.0
- org.apache.linkis:linkis (Maven): affected from 1.3.0; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29847/ (Markdown: https://insights.sbomify.com/CVE-2025-29847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29847
- OSV: https://osv.dev/vulnerability/CVE-2025-29847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29847/
Summaries are generated and may contain mistakes; the official description above is the record.
