# CVE-2025-29891: Apache Camel: Camel Message Header Injection through request parameters

> Attackers can inject Camel-specific headers via HTTP parameters to trigger code execution in vulnerable components like camel-exec.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2025
- **Updated:** 19 Mar 2025
- **Also known as:** GHSA-96v5-c2h5-56hm

## What is CVE-2025-29891?

CVE-2025-29891 is a medium-severity code injection vulnerability in Apache Camel, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bypass/Injection vulnerability in Apache Camel.

This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4.

Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases.

This vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component.

If you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers. 

The headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation.

All the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box.

This CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determined that it is also exploitable via HTTP parameters. Like in CVE-2025-27636, exploitation is only possible if the Camel route uses particular vulnerable components.

Weakness: CWE-164 (Improper Neutralization of Internal Special Elements)

## Which versions are affected by CVE-2025-29891?

6 open source packages ship an affected version, including org.apache.camel:camel-support. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-support` | Maven | From 3.10.0 | 3.22.4 |
| `org.apache.camel:camel-support` | Maven | From 3.10.0 | 3.22.4 |
| `org.apache.camel:camel-support` | Maven | From 4.0.0-M1 | 4.8.5 |
| `org.apache.camel:camel-support` | Maven | From 4.0.0-M1 | 4.8.5 |
| `org.apache.camel:camel-support` | Maven | From 4.9.0 | 4.10.2 |
| `org.apache.camel:camel-support` | Maven | From 4.9.0 | 4.10.2 |

Products: Apache Camel.

## How do I fix CVE-2025-29891?

Upgrade org.apache.camel:camel-support to a fixed version for your release line: 3.22.4, 4.8.5 or 4.10.2.

## Is CVE-2025-29891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29891 exists.

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-29891 and fix it if it is affected.

What it is: CVE-2025-29891 is a medium-severity code injection vulnerability in Apache Camel, published on 12 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-29891 exists.

Affected packages and fixed versions:
- org.apache.camel:camel-support (Maven): affected from 3.10.0; fixed in 3.22.4
- org.apache.camel:camel-support (Maven): affected from 3.10.0; fixed in 3.22.4
- org.apache.camel:camel-support (Maven): affected from 4.0.0-M1; fixed in 4.8.5
- org.apache.camel:camel-support (Maven): affected from 4.0.0-M1; fixed in 4.8.5
- org.apache.camel:camel-support (Maven): affected from 4.9.0; fixed in 4.10.2
- org.apache.camel:camel-support (Maven): affected from 4.9.0; fixed in 4.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-29891/ (Markdown: https://insights.sbomify.com/CVE-2025-29891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-29891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-29891
- OSV: https://osv.dev/vulnerability/CVE-2025-29891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-29891/
Summaries are generated and may contain mistakes; the official description above is the record.
